[maemo-developers] Crash in maemo-launcher

From: Tommi Komulainen tommi.komulainen at nokia.com
Date: Wed Mar 7 13:33:14 EET 2007
On Tue, 2007-03-06 at 11:38 -0600, ext Matt Hoosier wrote:
> The relevant libraries in my build here are stock Glib 2.12.0, Gtk+
> 2.10.6, and Pango 1.14.5. Are there any particular patches applied to
> Maemo's build of Pango, which are known to be required by the
> maemo-launcher? Alternately, it looks like the trouble reported by the
> various Pango functions above could be caused by an invalid
> GtkSettings object. Perhaps there's some other relevant bit in the
> Maemo fork of Gtk+ which I should be including?

maemo-launcher (the gtk booster) is incompatible with gtk+ 2.10, we
haven't worked on fixing the issue yet.


The crash is simply because the launcher (ab)uses the knowledge of gtk
using pango/xft internally which is no longer valid assumption with 2.10
as it uses pango/cairo.

Tommi Komulainen                            <tommi.komulainen at nokia.com>

More information about the maemo-developers mailing list