[maemo-commits] [maemo-commits] r13516 - in projects/haf/trunk/gtk+: . gtk

From: subversion at stage.maemo.org subversion at stage.maemo.org
Date: Fri Aug 31 12:01:05 EEST 2007
Author: xan
Date: 2007-08-31 12:01:00 +0300 (Fri, 31 Aug 2007)
New Revision: 13516

Modified:
   projects/haf/trunk/gtk+/ChangeLog
   projects/haf/trunk/gtk+/gtk/gtkentrycompletion.c
Log:
Name unused variable dummy.


Modified: projects/haf/trunk/gtk+/ChangeLog
===================================================================
--- projects/haf/trunk/gtk+/ChangeLog	2007-08-31 08:52:59 UTC (rev 13515)
+++ projects/haf/trunk/gtk+/ChangeLog	2007-08-31 09:01:00 UTC (rev 13516)
@@ -1,6 +1,12 @@
 2007-08-31  Xan Lopez  <xan.lopez at nokia.com>
 
 	* gtk/gtkentrycompletion.c (_gtk_entry_completion_resize_popup):
+	use "dummy" as the name for unused parameter to gdk_rectangle_intersect
+	to avoid confusions.
+	
+2007-08-31  Xan Lopez  <xan.lopez at nokia.com>
+
+	* gtk/gtkentrycompletion.c (_gtk_entry_completion_resize_popup):
 	use the new direction and height algorithm even when there are
 	no INPUT_AREAS, as it limits the height correctly.
 

Modified: projects/haf/trunk/gtk+/gtk/gtkentrycompletion.c
===================================================================
--- projects/haf/trunk/gtk+/gtk/gtkentrycompletion.c	2007-08-31 08:52:59 UTC (rev 13515)
+++ projects/haf/trunk/gtk+/gtk/gtkentrycompletion.c	2007-08-31 09:01:00 UTC (rev 13516)
@@ -1451,9 +1451,9 @@
 
       for (i = 0; i < n_rects; i++)
         {
-          GdkRectangle dest;
+          GdkRectangle dummy; /* Unused, have to pass something to intersect */
 
-          if (gdk_rectangle_intersect (&widget_rect, &rectangles[i], &dest))
+          if (gdk_rectangle_intersect (&widget_rect, &rectangles[i], &dummy))
             {
               if (rectangles[i].y + rectangles[i].height < root_y &&
                   (top == NULL || top->y + top->height < rectangles[i].y + rectangles[i].height))


More information about the maemo-commits mailing list