[maemo-commits] [maemo-commits] r15700 - projects/haf/trunk/gtk+/debian

From: subversion at stage.maemo.org subversion at stage.maemo.org
Date: Mon Jun 30 14:18:11 EEST 2008
Author: klattimer
Date: 2008-06-30 14:18:10 +0300 (Mon, 30 Jun 2008)
New Revision: 15700

Modified:
   projects/haf/trunk/gtk+/debian/changelog
Log:
Updated debian changelog for integration

Modified: projects/haf/trunk/gtk+/debian/changelog
===================================================================
--- projects/haf/trunk/gtk+/debian/changelog	2008-06-30 10:52:16 UTC (rev 15699)
+++ projects/haf/trunk/gtk+/debian/changelog	2008-06-30 11:18:10 UTC (rev 15700)
@@ -1,3 +1,195 @@
+gtk+2.0 (2:2.12.9-0osso3) unstable; urgency=low
+
+  * gtk/tests/treeview-hildon.c: s/g_return_if_fail/g_assert/.
+  * Implement GtkIconView behavior changes that are only in effect
+    when the hildon-mode style property is set to HILDON_FREMANTLE.
+  * gtk/gtkiconview.c (gtk_icon_view_class_init),
+    (gtk_icon_view_init), gtk_icon_view_[gs]et_property),
+    (gtk_icon_view_set_hildon_ui_mode): introduce hildon-ui-mode property,
+    (gtk_icon_view_style_set): reset hildon-ui-mode,
+    (gtk_icon_view_expose): draw tickmark over item when necessary,
+    (gtk_icon_view_motion), (gtk_icon_view_button_press),
+    (gtk_icon_view_button_release): add new-style row selection and
+    activation behaviors,
+    (gtk_icon_view_set_cursor),
+    (gtk_icon_view_move_cursor_up_down),
+    (gtk_icon_view_move_page_up_down),
+    (gtk_icon_view_move_cursor_left_right),
+    (gtk_icon_view_move_cursor_start_end): disable cursor movement in
+    new-style,
+    (verify_items), (gtk_icon_view_row_inserted),
+    (gtk_icon_view_row_deleted): enforce one-must-be-selected rule,
+    (gtk_icon_view_set_selection_mode): guard changes to selection mode in
+    normal-mode,
+    (free_queued*item): new functions.
+  * gtk/tests/Makefile.am:
+  * gtk/tests/iconview-hildon.c: add selftest.
+  * tests/Makefile.am:
+  * tests/testhildoniconview.c: add interactive test.
+  * Implement GtkTreeView behavior changes that are only in effect
+    when the hildon-mode style property is set to HILDON_FREMANTLE.
+  * gtk/gtkenums.h: add HildonUIMode.
+  * gtk/gtktreeview.c (gtk_tree_view_class_init),
+    (gtk_tree_view_init), gtk_tree_view_[gs]et_property),
+    (gtk_tree_view_set_hildon_ui_mode): introduce hildon-ui-mode property,
+    (gtk_tree_view_size_allocate_columns): allocate size for the
+    tickmark when needed,
+    (validate_row): request space for tickmark when needed,
+    (gtk_tree_view_bin_expose): render tickmark when needed,
+    (gtk_tree_view_button_press), (gtk_tree_view_button_release),
+    (gtk_tree_view_motion_bin_window), (gtk_tree_view_real_set_cursor):
+    add new-style row selection and activation behaviors,
+    (gtk_tree_view_style_set): reset hildon-ui-mode,
+    (gtk_tree_view_row_inserted), (gtk_tree_view_row_deleted),
+    (gtk_tree_view_set_model): enforce one-must-be-selected rule,
+    (gtk_tree_view_focus_to_cursor),
+    (gtk_tree_view_move_cursor_start_end): disable cursor,
+    (free_queued_*row): new functions.
+  * gtk/gtktreeprivate.h: add newly needed fields.
+  * gtk/gtktreeselection.c (gtk_tree_selection_set_mode): guard
+    changes to selection mode in normal-mode,
+    (_gtk_tree_selection_row_is_selectable): in normal-mode, no
+    rows are selectable,
+    (_gtk_tree_selection_internal_select_node): enforce
+    one-must-be-selected rule.
+  * gtk/tests/Makefile.am:
+  * gtk/tests/treeview-hildon.c: add selftest.
+  * tests/Makefile.am:
+  * tests/testhildontreeview.c: add interactive test.
+  * gtk/gtkimcontext.c (gtk_im_context_class_init):
+  * gtk/gtkentry.c (gtk_entry_class_init):
+  * gtk/gtktextview.c (gtk_text_view_class_init): use
+    HILDON_TYPE_GTK_INPUT_MODE instead of GTK_TYPE_GTK_INPUT_MODE.
+  * gdk/Makefile.am:
+  * gdk-pixbuf/Makefile.am:
+  * gtk/Makefile.am:
+  * perf/Makefile.am: do not hard code the prefix of the enum,
+    use @ENUMPREFIX@ instead.
+  * gtk/gtkwidget.c (gtk_widget_class_init): use HILDON_TYPE_MODE
+    for the hildon-mode style property instead of GTK_TYPE_MODE.
+  * gtk/gtkenums.h: add a temporary define to map
+    GTK_TYPE_GTK_INPUT_MODE to HILDON_TYPE_GTK_INPUT_MODE.
+  * Merge the testing framework and all unit tests from upstream
+    trunk as of today (too many commits in upstream to have their
+    ChangeLog entries copied here, thus only a summary):
+  * configure.in: depend on glib >= 2.15.0, add gtk/tests/Makefile
+  * Makefile.decl: makefile snippet to be included by all other
+    makefiles to put the test rules in place.
+  * */Makefile.am: include Makefile.decl in all makefiles.
+  * gdk/gdktestutils.h: new GDK test utils header.
+  * gdk/gdk.h: include it.
+  * gdk/gdk.symbols: add its symbols.
+  * gdk/directfb/gdktestutils-directfb.c
+  * gdk/quartz/gdktestutils-quartz.c
+  * gdk/win32/gdktestutils-win32.c
+  * gdk/x11/gdktestutils-x11.c: implement it in the various
+    backends.
+  * gtk/gtktestutils.[ch]: new GTK+ test utils files.
+  * gtk/gtk.h: include it.
+  * gtk/gtk.symbols: add its symbols.
+  * gtk/tests/pixbuf-init.c
+  * gtk/tests/textbuffer.c
+  * gtk/tests/defaultvalue.c
+  * gtk/tests/filechooser.c
+  * gtk/tests/floating.c
+  * gtk/tests/treeview-scrolling.c
+  * gtk/tests/builder.c
+  * gtk/tests/object.c
+  * gtk/tests/liststore.c
+  * gtk/tests/recentmanager.c
+  * gtk/tests/treestore.c
+  * gtk/tests/testing.c: unit tests. Some are moved from toplevel/tests
+    (note that these are not removed from there in maemo-gtk, but they
+    don't hurt either and toplevel/tests will by synced with upstream
+    on the next gtk upgrade). Some tests had to be edited because
+    they test vnew features of trunk that are not yet available in
+    maemo-gtk.
+  * Merge pixmap redirection code from upstream trunk, consisting of
+    the 8 indented commits below. Merged all commits completely even
+    if they affect unrelated files or non-X11 backends in order to
+    make applying of future offscreen rendering patches easier:
+  * gdk/gdk.symbols: Remove duplicate
+    gdk_window_redirect_to_drawable and gdk_window_remove_redirection
+  * gtk/gtk.symbols: Remove duplicate gtk_widget_get_snapshot
+  * **/makefile.msc gtk/makefile.msc.in : updated
+  * gtk/gtkwidget.c : fix c99ism (variable at start of block
+  * gdk/gdk.symbols gtk/gtk.symbols : export functions for window 
+    redirection
+  * gtk/gtkfilechooserdefault.c : #include <locale.h> for 
+    setlocale(LC_ALL, ...)
+  * gdk/gdk.symbols: Add gdk_window_redirect_to_drawable and
+    gdk_window_remove_redirection.
+  * gdk/win32/gdkwindow-win32.c (_gdk_window_new)
+    (_gdk_window_reparent): Rename to adapt to the offscreen rendering
+    changes. Remove now unnecessary parameter checks as the caller
+    does that already.
+  * gtk/gtk.symbols: Add gtk_widget_get_snapshot.
+  * gdk/quartz/gdkwindow-quartz.c:
+    (_gdk_window_new), (_gdk_window_reparent): Renamed to adapt to the
+    offscreen rendering changes, fixes build.
+  * gtk/gtkwidget.c: guard gtk_widget_get_snapshot() against
+    invalid or invisible widgets.
+  * gtk/gtkwidget.h: added GdkRectangle *clip_rect to gtk_widget_get_snapshot().
+  * gtk/gtkwidget.c: clip the returned snapshot pixmap to clip_rect.
+    return snapshot pixmap coordinates widget relative in *clip_rect.
+  * tests/testgtk.c: fixed bogus NULL pointer unref.
+  * gtk/gtkwidget.c gtk_widget_get_snapshot(): grow snapshot area from
+    widget's allocation to cover extra widget windows placed outside the
+    widget allocation (spinbutton arrows are the prime example for this).
+  * Applied pixmap redirection patch by Alexander Larsson with
+    various updates from:
+    Bug 318807 – Offscreen windows and window redirection.
+    Updates:
+  * updated docs to mention "Since 2.16".
+  * tests/testgtk.c: fixed snapshooting pixmap leak.
+    convert pixmap to pixbuf after snapshooting, to compensate for different
+    bit depths (occurs when snapshooting ARGB visuals and displaying the
+    pixmap in an RGB visual).
+  * gdk/gdkwindow.[hc]: made GdkWindowRedirect private.
+  * gdk/gdkwindow.c: removed damage idle handler, there's no aparent
+    need for it. enqueue damage notification as GDK_DAMAGE events
+    for each painting redirection at the start of the event queue.
+    consider windows with a redirection fully visible when invalidating,
+    and when updating from backing store. cleaned up stale variables.
+  * gdk/gdkevents.c: added _gdk_event_queue_prepend().
+  * gtk/gtkwidget.c: fixed coordinates for !NO_WINDOW widgets in
+    gtk_widget_get_snapshot; this fixes garbage snap offsets for gammacurve,
+    tree, drawingarea, text, handlebox, etc.
+    clip the redirected window hierarchy to window sizes, the visible
+    rectangles don't need to be taken into account here.
+    extended snapshooting docs to recommend gdk_pixbuf_get_from_drawable()
+    in case pixmap visuals could mismatch.
+  * gdk/x11/gdkwindow-x11.c: removed _gdk_windowing_window_get_visible_rect().
+  * tests/testgtk.c: add a "Snapshot" test to demonstrate snapshooting
+    of possibly obscured widgets into an offscreen pixmap.
+  * gtk/gtkwidget.[hc]: add GtkWidget::damage-event signal, add
+    gtk_widget_get_snapshot() to render a widget's contents to a GdkPixmap.
+  * gtk/gtkmain.c: dispatch GDK_DAMAGE events.
+  * gdk/gdkwindow.c: moved outer gdk_window_new() and gdk_window_reparent()
+    implementations here, adapted them to propagate redirects to child windows.
+    gdk_window_end_paint(): copy repainted window contents to redirection pixmap,
+    clipped to visible region. queue GDK_DAMAGE event delivery.
+    gdk_window_redirect_to_drawable(): install window painting redirection.
+    gdk_window_remove_redirection(): remove previously installed redirection.
+  * gdk/x11/gdkwindow-x11.c: added _gdk_windowing_window_get_visible_rect(),
+    renamed _gdk_window_new() and _gdk_window_reparent().
+  * gdk/gdkwindow.h: added GdkWindowRedirect* to GdkWindowObject, export
+    gdk_window_redirect_to_drawable() and gdk_window_remove_redirection().
+  * gdk/gdkevents.h: added GDK_DAMAGE event type.
+  * gdk/gdkevents.c: extract time and state from GDK_DAMAGE events.
+  * gdk/gdkinternals.h: added internal prototypes.
+  * gtk/gtkentry.[hc]: introduced hildon_gtk_entry_set_progress_adjustment()
+    to set an adjustment as progress indicator on GtkEntry widgets.
+  * Fixes: NB#86115: maemo-launcher does not work with
+    gtk_init_with_args(). Merged from upstream trunk:
+  * Bug 537985 – gtk_init_with_args() doesn't open a display after
+    gtk_parse_args()
+  * gtk/gtkmain.c (gtk_init_with_args): Open the default display
+    even when gtk_parse_args() has already been called.
+    Patch by Mathias Hasselmann
+
+ -- Karl Lattimer <karl.lattimer at nokia.com>  Mon, 30 Jun 2008 14:08:03 +0300 
+
 gtk+2.0 (2:2.12.9-0osso2) unstable; urgency=low
 
   * gtk/gtkentry.c (gtk_entry_set_progress_adjustment): new function to


More information about the maemo-commits mailing list