[maemo-developers] [maemo-developers] Re: USBNET networking

From: Keppler Alecrim alecrim at gmail.com
Date: Sat Aug 12 17:20:22 EEST 2006
Hi ,
        That is my fisrt post here. I've done a quick howto about USB
network with my steps and I compare with that on maemo page. The difference
is in your machine configuration. You need some modules to use USB network.
I needed to recompile with some options , like :
Device Drivers
USB support
USB Network Adapters
Multi-purpose USB Networking Framework
Simple USB Network Links (CDC Ethernet subset)
[*] Embedded ARM Linux links (iPaq, ...)
USB Gadget Support
<*> Support for USB Gadgets
<*> USB Gadget Drivers (Ethernet Gadget (with CDC Ethernet support))

Networking support (NET [=y])
Networking options
Network packet filtering (replaces ipchains) (NETFILTER [=y])
IP: Netfilter Configuration
<*> Connection tracking (required for masq/NAT)

And load the modules :

modprobe  cdc_ether

The complete howto is on http://franciscoalecrim.blogspot.com

On 8/12/06, Kalle Vahlman <kalle.vahlman at gmail.com> wrote:
> 2006/8/12, ThomasBambrough <thomas.bambrough at charter.net>:
> >
> >  I tried the steps outlined in the document and was able to load the
> usb0
> > interface on the 770. But, when I attempt to startup the usb0 interface
> on
> > the pc I get the following error
> >
> >  SIOCSIFADDR: No such device
> >  usb0: ERROR while getting interface flags: No such device
> >  SIOCSIFNETMASK: No such device
> >  SIOCSIFBRDADDR: No such device
> >  usb0: ERROR while getting interface flags: No such device
> >  usb0: ERROR while getting interface flags: No such device
> >  Failed to bring up usb0.
> >
> >  Can someone interpret this and tell me what I might be doing wrong. I
> have
> > tried this scenario on 3 different computers with different version of
> the
> > OS.
> Do you have the cable connected and 770 interface up when you do that on
> the PC?
> --
> Kalle Vahlman, zuh at iki.fi
> Powered by http://movial.fi
> Interesting stuff at http://syslog.movial.fi
> _______________________________________________
> maemo-developers mailing list
> maemo-developers at maemo.org
> https://maemo.org/mailman/listinfo/maemo-developers

Francisco Keppler Silva Alecrim
Instituto Nokia de Tecnologia (INdT) - OSMRC
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-developers/attachments/20060812/9eac3050/attachment.htm 
More information about the maemo-developers mailing list