[maemo-developers] [maemo-developers] Canola: other apps won't start

From: krischan.keitsch at alumni.tu-berlin.de krischan.keitsch at alumni.tu-berlin.de
Date: Thu Dec 7 20:07:51 EET 2006
Hi Marcelo,

thanks for the reply. I would like to make some points more clear:

1) I really love Canola and I appreciate the effort the caola team went 
trough! I am impressed by the smooth functionality, the eye candy, the user 
interface and the web based configuration client! Well done! Keep going.

2) Of course I understand that the n770 resources are limited and that I can't 
expect that many memory intensive apps can run _besides_ Canola. 

But I am dealing here with a problem when Canola is _not_ running!
* Desktop applet switched off
* Conola not running
* /etc/canola-conf stop as root in xterm / ssh
* killall canola-conf as root in xterm / ssh

I start the mail client (works), then the web browser visiting one of my 
favourite n770 related site (works) and then try to start the application 
manager (nope, won't work) or the xterm (not working).

Some more info:

1) I use a swap partition: /dev/mmcblk0p2, Memory is avaible!
Nokia770-26:~# free
              total         used         free       shared      buffers
  Mem:        61968        59352         2616            0           40
 Swap:        40888        26500        14388
Total:       102856        85852        17004

2) Is Canola still running? No!
ps -l |grep canola  --> nothing, same with canola-conf

3) Checking if I have enough free disk space: yep!
Nokia770-26:~# df -h
Filesystem			Size		Used		Available 	Use% 	Mounted on
/dev/mtdblock4		2.0M		2.0M         0 		100% 	/mnt/initfs
none				512.0k	60.0k	452.0k	12%		/mnt/initfs/tmp
/dev/mtdblock4		123.5M	115.9M	7.6M		94% 	/
none				512.0k	60.0k	452.0k	12%		/tmp
none				1.0M		44.0k	980.0k	4%		/dev
/dev/mmcblk0p1	1.9G		1.5G		301.1M	83%		/media/mmc1

4) System information: I am still using the "old" itos 2006 26-g version
Nokia770-26:~# uname -a
Linux Nokia770-26 2.6.16-omap1 #3 PREEMPT Thu Nov 2 01:29:14 CET 2006 
armv5tejl unknown
This all began after I installed Canola. Did Canola change any watchdog 
settings or something like this? Or Am I dealing here with a corrupt 
filesystem / ram or swap partition?

As soon as I quit the mail client or the webbrowser I am able to launch xterm

I am looking forward to updates and new Canola features! Maybe I should just 
reflash my n770 with itos 2006 39-14.

Thanks again! And greetings from Germany (experiencing the warmest December 


Am Donnerstag, 7. Dezember 2006 04:39 schrieben Sie:
> Hi Krischan,
> I tried what you've said... open more application with canola running.
> Of course I was not able to run like I would if canola was not running,
> but I could easy open :
> 1) full web site ( brazil's biggest web portal )
> 2) the Rss reader
> 3) The regular audio player
> 4) Xterm
> 5) 1 more web site : the lonely planet
> After that yes, the 770 refuses to open more application, because
> there's no more memory available.
> But I will clarify to you: It;s not a bug.
> Why do I say tha : Because canola needs memory to run, there's no
> miracle behind it that would make it run with a small amount of
> memory. We did our best:
> kept images number / size at the minimum, tried to avoid any kind of
> replication, took a lot of care in the  code to manage memory in the
> right way, but canola does use a reasonable amount of memory. The UI
> that we are able to provide you has a price, and unfortunately
> there's not much left to do to reduce that.
> What I can do I'm doing right now, everyday : refusing request, new
> features, more animation in the themes, etc.
> Now what are we doing?
> We are focusing on reducing cpu usage. This we can do. But of
> course.. again not miracles, doing smooth animation is heavy and cpu-
> intensive so Canola WILL always consume more cpu than the default
> player. The default player is a static GTK (native) application. GTK
> is already loaded in the memory, and as you don't have nothing with
> smooth animation the cpu is almost zero.
> When you posted, I read " I cannot run anything "  and that scarred
> me a lot =)
> I hope you understand my message as a positive, well-humored one, and
> not an angry one ok? It's just because sometimes  we forget that the
> 770 is a very humble machine when it comes to memory and cpu!
> BR from brazil,
> Marcelo Oliveira
> On Dec 6, 2006, at 6:24 PM, krischan.keitsch at alumni.tu-berlin.de wrote:
> > Hi Antonio,
> >
> > I just wanted to find out if anybody else came across this
> > behavior. I will
> > then add a bug report to the canola-garage site.
> >
> > Did you install canola? If so, can you run several apps (web and
> > mail client)
> > and then launch e.g. xterm and even more apps?
> >
> > Regards
> >
> > Am Mittwoch, 6. Dezember 2006 21:08 schrieben Sie:
> >> zrz,
> >>
> >> it is better to feedback indt canola guys about it ?!
> >> marcelo.oliveira at indt.org.br
> >>
> >> regards
> >>
> >> On 12/5/06, Zrz <krischan.keitsch at alumni.tu-berlin.de> wrote:
> >>> Hi
> >>>
> >>> I installed Canola (great app btw) and noticed that other apps won't
> >>> start anymore, even when there is enough swap space available.
> >>>
> >>> For example: I have Opera and the mail client runing and want to
> >>> launch a
> >>> third app. I see a high cpu load which fades away after some
> >>> seconds but
> >>> the app will not start.
> >>>
> >>> Before I installed Canola I was able to run as many apps as I wanted
> >>> until I ran out of swap space.
> >>>
> >>> I still use itos 2006 28-6, have a 40mb swap partition and the
> >>> urgend
> >>> feeling that something has changed! This unwanted new behavior is
> >>> annoying. My n770 behaves as if it is running out of memory.
> >>>
> >>> Did anyone noticed a similar behavior? If so I would like to
> >>> track this
> >>> down and add a bug report to garage.
> >>>
> >>> Thanks and regards
> >>>
> >>> Krischan
> >>>
> >>> PS: Canola runs great as stand alone app!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.maemo.org/pipermail/maemo-developers/attachments/20061207/801b07b0/attachment.pgp 
More information about the maemo-developers mailing list