[maemo-developers] [maemo-developers] flasher not flashing rootfs?

From: DJ Delorie dj at delorie.com
Date: Wed Dec 13 18:48:58 EET 2006
> Well, then it looks OK. Maybe your image is too small (4MB from your 
> output? some test?)

I was working on a "minimum rootfs to get a console shell" test.  The
next step is "minimum rootfs to get an X app".

> In any case if you are sure the image is ok and want experiment with 
> booting from mmc, have a look here 

What I did yesterday is make an ext2 file system image on my desktop,
then dd it over to the 770 right into the mmc card (using Nokia's 2.1
rootfs, which I can flash).  Now I can boot off the mmc card.  I need
to get a bigger card if I want to go much further with this, though

> Flashing rootfs can be done with this too when booted from mmc. Tried 
> myself.

Assuming you have a big enough mmc to hold a full rootfs image.  I
still only have the pre-supplied 64m card.

But, I'll keep that in mind.  It would be better if the flasher just
worked, or at least told me why it wasn't.

More information about the maemo-developers mailing list