[maemo-developers] [maemo-developers] Troubles installing Herring

From: Aniello Del Sorbo anidel at gmail.com
Date: Wed Dec 20 18:43:06 EET 2006

it's been three days since I've been trying to install Herring/Sardine 
onto my 770 ("Melkor").

At first I tried to install Sardine, but whenever I booted Melkor from 
the MMC I got a white screen (as explained in this bug report:


Thus I choose to try our Herring.

I decided to start from scratch: I flashed Melkor to IT2006 
(SU-18_2006SE_2.2006.39-14_PR_F5_MR0_ARM) and installed OSSO XTerm and 
flashed with the new initfs as explained in the instructions.

Copied the IT2006 onto the MMC again and tried to boot from it. It worked.

Restarted from the flash, I then chrooted to /opt, changed the 
sources.list (I just left the herring repository inside) and did this:

apt-get update (worked fine)
apt-get install hildon-application-framework

This already gave me some errors (same as Sardine however), specifically:

/bin/sh: /usr/sbin/dpkg-preconfigure: not found


ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or 

(the latter, of course, for many packages)

I went forward and did the:

apt-get upgrade

it gave me the very same errors (sardine had more, so I think that was 
related to some relatively new changes to the sardine reps) plus this:

* Updating MIME database in /usr/share/mime...
* Warning: Unknown media type in type 'sketch/png'

(every now and then)


Setting up libx11-6 (1.0.0-6osso4) ...
fgrep: invalid option -- x

moreover, when it tried to stop maemo-launcher it told me that that was 
not running:

Stopping Maemo Launcher: maemo-launcher not running.

while, when trying to starting it up again:

Installing new version of config file /etc/init.d/maemo-launcher ...
Starting Maemo Launcher: maemo-launchermaemo-launcher[3539]: GLIB 
CRITICAL ** Gdk - gdk_display_close: assertion `GDK_IS_DISPLAY 
(display)' failed

maemo-defender: died stating file a: '/proc/3541/exe'
maemo-launcher: error rising the oom shield for pid=3541 status=7680

and it stopped here.

an: apt-get upgrade  didn't give me any issues, so I tried to reboot.
I kept the MENU key pressed, but it keeps booting from flash (even if I 
read the line "keep MENU key pressed for advanced options bla bla"...)

Did something went really wrong ? and what ?

 From what I have understood the first errors should be normal and cause 
no harm. But the last ones ?

Any ideas ?


More information about the maemo-developers mailing list