[maemo-developers] [maemo-developers] Running GUI programs as root...

From: Tomi Ollila tomi.ollila at guru.guru-group.fi
Date: Tue Feb 28 19:02:26 EET 2006

When I tried to run gui program as root it just died.
after trying from xterm it printed something about sapwood server

I remote-logged to N770, sudoed root and run the prg as follows:

# DISPLAY=:0.0 ./my-gui-prog

Now this worked, but the fonts and everything were quite small ("default" GTK look)..

I diffed the environment between local and remote xterms and then tried:

# GTK2_RC_FILES=/home/user/.osso/current-gtk-theme DISPLAY=:0.0 ./my-gui-prog
my-gui-prog[1105]: GLIB ERROR ** default - sapwood-theme: Failed to load pixmap file
Failed to connect to sapwood server using `/tmp/sapwood-:0.0': Connection

        `/usr/lib/sapwood/sapwood-server' MUST be started before


Now I diffed the sudoed and non-sudoed environments, then tried all
differences one by one and got

# TMPDIR=/var/tmp GTK2_RC_FILES=/home/user/.osso/current-gtk-theme DISPLAY=:0.0 ./my-gui-prog

working... It is interesting that directory /var/tmp is empty.

Pretty weird I'd say... and more weird is that one of the right-side
buttons in my gui prog is not displayed (gone over the edge or

Well, back to test more ;/. Any comments...


More information about the maemo-developers mailing list