[maemo-developers] [maemo-developers] Toolchain still not working...new clues

From: Eero Tamminen eero.tamminen at movial.fi
Date: Mon May 29 09:49:47 EEST 2006

> after lots of tries, I dropped Xnest and tried Xvnc.
> It also didn´t worked. I also tested running any X
> Application under scratchbox...also didn´t worked.

Have you allowed them to connect to the X server
(be it your desktop one, or Xephyr)?

With Xephyr you can use just "-ac" to disable all access
control (and set Xephyr not to accept TCP connections
with the standard "-nolisten tcp" X server option[1]).
With the desktop X you can do something like:
- outside Sbox:
	xhost +localhost
  or just
- copy the ~/.Xauthority file from your home directory
  to your home directory inside Sbox

Desktop X servers are nowadays normally configured so that
they don't allow TCP connections, just local unix socket
connections[1].  "sb-init.sh" should be run with DISPLAY
environment NOT having the host address part, like this:
	DISPLAY=:1 sb-init.sh start

	- Eero

[1] This is done for obvious security reasons. X doesn't have
any security between the clients, all clients can manipulate
each others resources and events as they wish.

More information about the maemo-developers mailing list