[maemo-developers] [maemo-developers] Re: Toolchain still not working...new clues

From: Daniel Monteiro junkybox2002 at yahoo.com.br
Date: Mon May 29 18:47:15 EEST 2006
Must be it!
im using "localhost", as it cant accept the display
without it. there must be some workaound.

Daniel "NeoStrider" Monteiro

PS: I will also try to compile Xephyr and create a
debian package for it.

Date: Mon, 29 May 2006 09:49:47 +0300
From: Eero Tamminen <eero.tamminen at movial.fi>
Subject: [maemo-developers] Toolchain still not
working...new clues
To: maemo-developers at maemo.org
Message-ID: <20060529064947.GB29227 at movial.fi>
Content-Type: text/plain; charset=iso-8859-1


> after lots of tries, I dropped Xnest and tried Xvnc.
> It also didn´t worked. I also tested running any X
> Application under scratchbox...also didn´t worked.

Have you allowed them to connect to the X server
(be it your desktop one, or Xephyr)?

With Xephyr you can use just "-ac" to disable all
control (and set Xephyr not to accept TCP connections
with the standard "-nolisten tcp" X server option[1]).
With the desktop X you can do something like:
- outside Sbox:
	xhost +localhost
  or just
- copy the ~/.Xauthority file from your home directory
  to your home directory inside Sbox

Desktop X servers are nowadays normally configured so
they don't allow TCP connections, just local unix
connections[1].  "sb-init.sh" should be run with
environment NOT having the host address part, like
	DISPLAY=:1 sb-init.sh start

	- Eero

[1] This is done for obvious security reasons. X
doesn't have
any security between the clients, all clients can
each others resources and events as they wish.

Abra sua conta no Yahoo! Mail: 1GB de espaço, alertas de e-mail no celular e anti-spam realmente eficaz. 

More information about the maemo-developers mailing list