[maemo-developers] [maemo-developers] mounting squashfs-image fails with "block device required"

From: Sascha Heid saschaheid at gmail.com
Date: Sun Oct 1 01:14:22 EEST 2006
> > I added squashfs-support into the kernel so i can put the (german)
> > wikipedia on my 2gb card which squashfs compresses from 15GB to 1,8GB.
> On the 770 did you use cat /proc/filesystems to see squashfs in the list
> of supported file systems?  If you compiled the kernel as a module, then
>  did you copy it to your 770 and modprobe the module?

Yes i see squashfs in there and it does not have "nodev" in front of
it like most other fs do (i dunno what that means).
It is built into the kernel. First i patched the kernel assuming its
not already in since i couldn't find it in the defconfig. After
patching it i added CONFIG_SQUASHFS=m into the config and recompiled
the kernel.
After i realized the module was not copied onto my 770 i changed to
CONFIG_SQUASHFS=y and this worked.
I copied that kernel with ./flasher-2.0 -l -b -k
kernels/zImage-su-18-200639 btw which is the test-boot option.

> > The mount-command i use is "mount -t squashfs -o loop image.sqfs dir/"
> > but i get the error "Mounting ..... failed: Block device required".
> You can graft in file systems to any directory.  I'd try either an
> absolute path /mnt/dir i.e.
> mkdir /media/wiki
> "mount -t squashfs -o loop image.sqfs /media/wiki"
> or make sure that you are above the directory where you want to mount
> the device and use
> "mount -t squashfs -o loop image.sqfs dir"

Both doesn't work.

> If the mount command could not find you image file, then you'd receive
> "No such file or directory" instead. The focus needs to be on either the
> image.sqfs file or the squashfs.  Did you do an md5sum or where you
> provided a way to check the image.sqfs?  Could it be bad?

I copied the squashfs-image back to my laptop and "file" identified it
as squashfs-image:
Squashfs filesystem, little endian, version 3.0, 0 bytes, 5411 inodes,
blocksize: 65536 bytes, created: Mon Sep 25 20:48:02 2006".
I also can mount that squashfs-image on the laptop.

> > I also tried different options like -o loop=/dev/loop0, -o ro,loop or
> > -o loop=/dev/mtdblock0 (if you think this guy must be clueless you are
> > right) but with the same result.
> >
> > Does anyone know what to do here?
> >
> > I have /dev/loop, /dev/loop0,...,/dev/loop7.
> >
> Please check permissions on these devices. Make the other loop devices
> match brw------- 1 root root /dev/loop

The permissions of the /dev/loop entries have been brw-rw--- and
root:disk (on my laptop too) but changing them to brw------ and
root:root did not have any effect

> I could only find this with similar issues
> http://www.oesf.org/forums/index.php?showtopic=10201&st=15


> Did your kernel have all the suggestions here?
> http://www.artemio.net/projects/linuxdoc/squashfs/SquashFS-HOWTO.html

The image-file is right, the mount-command is right, i have squashfs
support in my kernel, i have loopback-devices, is there anything i


More information about the maemo-developers mailing list