[maemo-developers] [maemo-developers] mounting squashfs-image fails with "block device required"

From: Dirk Kuijsten dirk.kuijsten at xs4all.nl
Date: Sat Oct 7 18:25:38 EEST 2006
Op Wo, 27 september, 2006 20:00, schreef Sascha Heid:
> Hi List.
> I added squashfs-support into the kernel so i can put the (german)
> wikipedia on my 2gb card which squashfs compresses from 15GB to 1,8GB.
> The mount-command i use is "mount -t squashfs -o loop image.sqfs dir/"
> but i get the error "Mounting ..... failed: Block device required".
> I also tried different options like -o loop=/dev/loop0, -o ro,loop or
> -o loop=/dev/mtdblock0 (if you think this guy must be clueless you are
> right) but with the same result.
> Does anyone know what to do here?
> I have /dev/loop, /dev/loop0,...,/dev/loop7.
> Regards
> Sascha
> _______________________________________________
> maemo-developers mailing list
> maemo-developers at maemo.org
> https://maemo.org/mailman/listinfo/maemo-developers


I have been using squashfs successfully for months now to read my local
newspaper (html) every day on the 770 while on the train. For me this is
my killer app!
I think you should use losetup to use the loop device. My guess is the
mount program on the 770 doesn't support looping.
I use:

1. Insert squashfs kernel module: insmod squashfs.ko
2. /sbin/losetup /dev/loop1 file.sq
3. mount -t squashfs /dev/loop1 /mnt/directory

You need to compile util-linux for the losetup program. For the 2006
software version i have put it on my website:
I have also put the kernel module on this website (2006 kernel, 2.6.16):


Dirk Kuijsten.

More information about the maemo-developers mailing list