[maemo-developers] [maemo-developers] mounting squashfs-image fails with "block device required"

From: Greg Morgan drkludge at cox.net
Date: Sat Sep 30 21:58:47 EEST 2006
Hash: SHA1

Sascha Heid wrote:
> Hi List.
> I added squashfs-support into the kernel so i can put the (german)
> wikipedia on my 2gb card which squashfs compresses from 15GB to 1,8GB.
On the 770 did you use cat /proc/filesystems to see squashfs in the list
of supported file systems?  If you compiled the kernel as a module, then
 did you copy it to your 770 and modprobe the module?

> The mount-command i use is "mount -t squashfs -o loop image.sqfs dir/"
> but i get the error "Mounting ..... failed: Block device required".

You can graft in file systems to any directory.  I'd try either an
absolute path /mnt/dir i.e.
mkdir /media/wiki
"mount -t squashfs -o loop image.sqfs /media/wiki"
or make sure that you are above the directory where you want to mount
the device and use
"mount -t squashfs -o loop image.sqfs dir"
If the mount command could not find you image file, then you'd receive
"No such file or directory" instead. The focus needs to be on either the
image.sqfs file or the squashfs.  Did you do an md5sum or where you
provided a way to check the image.sqfs?  Could it be bad?

> I also tried different options like -o loop=/dev/loop0, -o ro,loop or
> -o loop=/dev/mtdblock0 (if you think this guy must be clueless you are
> right) but with the same result.
> Does anyone know what to do here?
> I have /dev/loop, /dev/loop0,...,/dev/loop7.
Please check permissions on these devices. Make the other loop devices
match brw------- 1 root root /dev/loop

I could only find this with similar issues

Did your kernel have all the suggestions here?

Please post back if you make progress or have success.

Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the maemo-developers mailing list