[maemo-developers] Failing to connect with flasher

From: Jeffrey Barish jeff_barish at earthlink.net
Date: Mon Apr 9 19:46:41 EEST 2007
Marius Gedminas wrote:

> On Sat, Apr 07, 2007 at 01:35:21PM -0600, Jeffrey Barish wrote:
>> I am trying to connect to my N800 with flasher.  It freezes with
>> Suitable USB device not found, waiting
> ...
>> I am on Kubuntu 6.10 using flasher 0.8.7.  Does anyone have a suggestion?
> You need flasher 3.0 for the N800.  You can get it at the usual place at
> maemo.org.
> Marius Gedminas

I am using the program described as

flasher-3.0  40236  flasher utility (Linux on Intel x86) for the Nokia N800
and 770



I checked the md5sum.  I downloaded the program again to be sure that this
is what I was using.  The program does run, but flasher --query-root-device
produces the above message.  I tried running the command first and then
plugging in the USB connection from the N800.  I tried connecting USB first
and then running the command.  I tried running the command as root.

There seem to be two problems.  The first is the one I mentioned before
(flash fails to open the device).  The ownership of the usb device is
root.root, which seems to be the case for all usb devices created at least
on Ubuntu.  When I change the ownership so that I have read/write
permission, flasher gets past the open command that produced the error I
reported originally.  However, the ioctl command then fails with

open("/dev/bus/usb/005/025", O_RDWR)    = 3
ioctl(3, USBDEVFS_IOCTL, 0xbfe10400)    = -1 ENOTTY (Inappropriate ioctl for
close(3)                                = 0

I don't see anything I can do to get around this one.  In fact, it looks
like a bug.  But how, then, is anyone else using flash-3.0 with an N800?
Jeffrey Barish

More information about the maemo-developers mailing list