[maemo-developers] Failing to connect with flasher

From: Jeffrey Barish jeff_barish at earthlink.net
Date: Tue Apr 10 18:14:34 EEST 2007
Marius Gedminas wrote:

> That's normal.  You run the flasher as root, then power off your N800,
> plug the USB cable, then power on the N800.  It will start talking to
> the flasher during its boot process.
> You can also hold down the Home key on the N800 while it's booting, to
> make sure it waits for the flasher.

I tried both of your suggestions without success.  And of course as soon as
I run flasher, before it even prints the message that it's waiting for a
suitable USB device, it has already made the error I reported previously:

ioctl(3, USBDEVFS_IOCTL, 0xbfd27320)    = -1 ENOTTY (Inappropriate ioctl for

If you were willing to run flasher under strace, it would be very
interesting to know what you see when flasher opens the USB device.  Maybe
flasher expects the ioctl call to fail, in which case something else is
wrong here.
Jeffrey Barish

More information about the maemo-developers mailing list