[maemo-developers] Failing to connect with flasher

From: pancake pancake at youterm.com
Date: Tue Apr 10 18:53:34 EEST 2007
> Marius Gedminas wrote:
>> That's normal.  You run the flasher as root, then power off your N800,
>> plug the USB cable, then power on the N800.  It will start talking to
>> the flasher during its boot process.
>> You can also hold down the Home key on the N800 while it's booting, to
>> make sure it waits for the flasher.

You can try with:

$ export USB_DEBUG=5

btw, is the n800 bricked? do you know if it arrives to the secondary?

If you want to play with the 0xFFFF source code I recommend you to add more
debugging info in the device detection code (main.c) and reduce the sleep
time between calls to find_usb_devs().

Try with this method:

 - remove the battery of the n800
 - plug the usb cable
 - run $ USB_DEBUG=5 0xFFFF -i
 - put the battery and click the power button.
 - wait for magic

> I tried both of your suggestions without success.  And of course as soon
> as
> I run flasher, before it even prints the message that it's waiting for a
> suitable USB device, it has already made the error I reported previously:
> ioctl(3, USBDEVFS_IOCTL, 0xbfd27320)    = -1 ENOTTY (Inappropriate ioctl
> for
> device)
> If you were willing to run flasher under strace, it would be very
> interesting to know what you see when flasher opens the USB device.  Maybe
> flasher expects the ioctl call to fail, in which case something else is
> wrong here.

I'm not at home, but I can later send you the lowlevel debug of the
flasher if you're interested.

BTW If you are able to boot Maemo but you're not able to connect to NOLO
you should probably think on reflashing nolo from the device (using
mtdtools). BTW this is not yet supported by 0xFFFF, but would be nice
to do it. You can look for a similar stuff on the bootmenu tarball.

If none of these things work, you will have to try to connect via the
undocummented and esotheric serial port.

Let me know


More information about the maemo-developers mailing list