[maemo-developers] [maemo-developers] Hildon Input Method

From: Kimitake Abe kimitake at gmail.com
Date: Tue Feb 13 17:50:30 EET 2007

Yes, I assumed "ja_JP" is displayed Text input settings GUI as
you mentioned.

I have installed my package again and show the GUI but
it is not displayed yet, but I run gconftool-2 command
(but I specified secondary_language), and the execute Note,
so I can find "ja_JP" in the menu of input method.

Text input settings GUI still does not show ja_JP as
2nd language.

Anyway, I can continue to modify my input method plugin.
Thank you very much.

# after rebooted N800, endless reboot issue happens again...


-----Original Message-----
From:    Mohammad Anwari <mohammad.anwari at nokia.com>
To:      ext Kimitake Abe <kimitake at gmail.com>
Date:    Tue, 13 Feb 2007 16:24:11 +0200
Subject: Re: [maemo-developers] Hildon Input Method

Pada hari Senin, tanggal 12/02/2007 pukul 12:31 -0800, ext Kimitake Abe
> I just modified the sample project and created lib such as
> himja-vkb.a(la,so) and installed to N800!
> But I cannot see the ja_JP etc. on the control panel's GUI.

Where do you expect the ja_JP would appear in cpanel?
It should be appear in Text Input Settings applet in control panel.

> So I have tried to reboot the device, and then it reboots and reboots
> again X-(
> Anyway, I have set hildon_im_plugin_info as follow, is it correct?
>    "himja_vkb_new", /* new func */
>     "himja_vkb", /* name */
>     "Keyboard (Japanese)", /* menu title */
>     NULL, /* gettext */
>     TRUE, /* visible in menu */
>     FALSE, /* cached */
>     IM_TYPE_KEYBOARD, /* type */
>     IM_GROUP_CJK, /* group */
>     DEFAULT_PRIORITY, /* priority */
>     NULL, /* no other plugin in SCV button */
>     ""      /* help page */
> And also I set as follow.
> gchar **
> hildon_im_plugin_get_available_languages (gboolean *free)
> {
>   static gchar *list[] = { "ja_JP", NULL };
>   *free = FALSE;
>   return list;
> }

I modify the sample to follow yours above and successfuly have it in the
But I manually change the language to Japanese first:

gconftool-2 -t string -s /apps/osso/inputmethod/primary_language ja_JP

More information about the maemo-developers mailing list