[maemo-developers] [maemo-developers] Speed test with vfp (floating point) on N800

From: Kalle Vahlman kalle.vahlman at gmail.com
Date: Fri Feb 16 11:55:41 EET 2007
2007/2/16, Simon Pickering <S.G.Pickering at bath.ac.uk>:
[libc/m with VFP]
> I note that the build process was a fiddle (mainly due to my not knowing the
> debian way), and it took a couple of goes before my CFLAGS were used for the
> build. I also note that when I tried using the following "-mcpu=arm1136j-s
> -mfpu=vfp -mfloat-abi=softfp", the build failed (I don't know why - didn't look
> too hard. I don't have cpu transparency setup though), but removing
> "-mcpu=arm1136j-s" worked, and that's what I've been using.

Yeah, that's due to licensing issues. Qemu cannot emulate ARMv6
instructions, thus the  build fails if it tries to run anything
compiled with the correct arch.

Tuomas (who did the builds for me) noticed that there was a configure
flag given for tje libc build that most likely prevented our version
from actually using the vfp (the fact that it still gave a performance
boost for us most likely comes from the missing thumb mode instead of
using hw floats...).

So we definitely need to rerun the tests we had once a better build is done...

Kalle Vahlman, zuh at iki.fi
Powered by http://movial.fi
Interesting stuff at http://syslog.movial.fi

More information about the maemo-developers mailing list