[maemo-developers] Trouble setting up Scratchbox

From: David Levine levine at pv.com
Date: Tue Jul 10 20:52:57 EEST 2007
A couple of things that might be relevant.

1. After installing scratchbox, you have to log out and come back in.
It's not sufficient to go to a new window!  Reason is, the group
accounting isn't fully propagated on a dynamic basis (as it rarely
changes).  The install has created a new group, 'sbox', and enrolled you
as a member, but until you login again you're not actually eligible..
  (I made this mistake)

2. Scratchbox uses "chroot" which can really confuse your view of the
world!  When you're inside scratchbox, you'll see a /home directory, but
that (on my system) is really at /scratchbox/users/me/home ..
  I've not yet discovered a way "out" of the scratchbox environment (to
see my "real" files).  I have found it helpful to set up a link the
other way, thus on my machine ~/sb is a symbolic link to the sbox home
directory mentioned above.  This is helpful in making up copies of the
source tree, for instance.

(I'm working on a CentOS (RedHat) system)

Good luck.

   David Levine

On Mon, 2007-07-09 at 12:41 -0700, Sean Bouchard wrote:

> Hi, all. Just got an N800 and I'd like to do some development on it, but
> I'm having trouble getting started. I'm trying to install Scratchbox on
> an Ubuntu Feisty Fawn machine, but I keep getting stuck. Any help would
> be appreciated!
> I've found a couple guides that I've tried to follow, most recently one
> by Ian Lawrance
> (http://ianlawrence.info/random-stuff/maemo-3-1-bora-on-ubuntu-feisty ).
> The install goes smoothly until I have to add a user to Scratchbox, and
> then it falls apart. When I try to run "/scratchbox/sbin/sbox_adduser
> bouchard yes" I get an error: "chown: 'bouchard:domain': invalid group",
> which doesn't mean anything to me. Despite this, it says that the user
> account has been added, but when I try to run maemo-sdk-install_3.1.sh,
> I get the following error:
> E: Scratchbox home directory '/scratchbox/users/bouchard/home/bouchard'
> not found.
> E: Add user with '/scratchbox/sbin/sbox_adduser bouchard'.
> If I run sbox_adduser again, it tells me that the user account already
> exists.
> Is it supposed to be looking for "home/bouchard/" in "users/bouchard/"?
> There is no "/scratchbox/home/" directory, which is what I would have
> expected. Does that "chown" error above mean anything, and could it be
> related?
> As I said, any help would be greatly appreciated. I haven't been able to
> find accounts of this error anywhere online, so if anyone has any ideas,
> please let me know!
> Thanks!
> _______________________________________________
> maemo-developers mailing list
> maemo-developers at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-developers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-developers/attachments/20070710/b8aeecf2/attachment.htm 
More information about the maemo-developers mailing list