[maemo-developers] User certificate issue

From: Robert Šmol robert.smol at dhl.com
Date: Fri May 18 15:11:43 EEST 2007
today I tried to connect to our WPA-EAP TLS based Wifi. I was able to
import our CA certificate but I'm unsuccessful importing my own
certificate. From Firefox I backuped my certificate with password and
saved as certificate.p12, this one cannot be imported using Certificate
Manager as it is always complaining about password incorrect even I'm
100% sure it is.

Then I tried to do:
rsmol at czchown05602 ~/Desktop/Work $ openssl pkcs12 -in certificate.p12
-clcerts -nodes -out certificate.pem
Enter Import Password:
MAC verified OK

And this one can be imported, but appears in Authorities tab instead of
in User tab and thus cannot be selected when creating WIFI connection.

Any ideas what am I doing wrong?

thank you
Robert Šmol, Ing.
Telecoms Tools Specialist 

DHL Information Services (Europe) s.r.o. 
V Parku 2308/10
148 00 Praha 4
Czech Republic 

phone: +420 288 80 1118 
email: robert.smol at dhl.com 
web: http://tools.telecom.dhl.com
im: rsmol at jabber.telecom.dhl.com
Get Firefox!    
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-developers/attachments/20070518/b301d420/attachment.htm 
More information about the maemo-developers mailing list