[maemo-developers] Unable to get device detected with usb host mode on N800

From: Tony Lindgren tony at atomide.com
Date: Wed May 23 18:07:04 EEST 2007

* Vasudevan Srinivasan <vazudevan at gmail.com> [070523 07:53]:
> Hi,
> I tried the usb host mode on n800 and was not success full in getting
> devices hooked up.
> These are the following that I have tried.
> 1. Compiled the kernel on SDK_ARMEL as per instructions at
> http://www.muru.com/linux/n800-usb-host/ with the following patches.
> kernel-source-rx-34_2.6.18-osso40.diff.gz
> patches-tusb-n800-2007-05-04.tar.gz
> - make n800_defconfig
> - make zImage
> - flasher -f -k -R /path/zImage
> 2. Switching to host mode - echo host > 
> /sys/devices/platform/musb_hdrc/mode
> throws on dmesg
> musb_platform_set_mode 461: Already in host mode otg_stat: 00000171
> 3. Used a mini-B  - TypeA cable to a powered usb hub with n800 connected to
> the host port.
> I could only get usb hub detected. other devices (usb flash disk, keyboard)
> connected the hub are not detected.
> restarting /etc/init.d/ke-recv did not help either.
> Is there something I'm missing? Any suggestions to get ahead?
> I also tried patches-tusb-n800-2007-04-18.tar.gz without success.

If the hub is working sounds like you're very close :)

Please check that you have the necessary host side drivers compiled
in or loaded as modules. Also, please check that you don't have
CONFIG_USB_OTG_WHITELIST enabled in .config.



More information about the maemo-developers mailing list