[maemo-developers] [pymaemo] How to add PyModule_AddObject to the override file?
From: Andrea Grandi a.grandi at gmail.comDate: Thu Jul 30 17:56:01 EEST 2009
- Previous message: [pymaemo] How to add PyModule_AddObject to the override file?
- Next message: [pymaemo] How to add PyModule_AddObject to the override file?
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]
Hi, 2009/7/30 Anderson Lizardo <anderson.lizardo at openbossa.org>: > One suggestion: rename the "PluginDescriptorPublic" PyObject to > "PyMafwPluginDescriptorPublic", to avoid a possible name clash with > symbols from other headers. Same for the type struct: > PluginDescriptorPublic_Type -> PyMafwPluginDescriptorPublic_Type. I > think codegen generated types use the "Py<C_type>" and > "Py<C_type>_Type" patterns due to this. binding is generated anyway, but I've renamed it to avoid name conflicts > Besides that, I can't really comment much on the code, I'll have to > trust that you tested the code and can modify the list_plugins I tested this type only from Python, I really don't know (yet) how to make list_plugins use it :P > override to be able to actually use this type. The current override > will certainly not work because it relies on each item of the list > being a GObject, as can be shown by this line: > > PyObject *item = pygobject_new((GObject *)g_list_nth_data(wlist, i)); yes I know... > Personally, I would probably opt for the "wrap around GType" method > described on that link too, because that way the overrides for the > methods that use that type could still use pygobject_new() to manage > instances. But that's just me, if you manage to make it work with > either methods (and have list_plugins() return valid instances of the > type), we would gladly accept your work :) I've tried the other way too, but I wasn't able to make it work... I could compile it but I had a "core dump" importing the module, so I don't know how to investigate what was the problem... > I can't really help you much on this, It's a whole new subject for me > and I'll probably not have time in the next weeks to play with > python-mafw code. ok, don't worry... I'll keep working on it as you know, it's enough if you can reply to my emails, I'll do all the tests I need. > On a separate note, all all these "raw" (non GObject based) structs > that MAFW uses would make a PyBank based binding somewhat difficult > too, given that there it relies 100% on GObject introspection, I > think. With codegen, it is at least easier to write custom Python type > wrappers if you know some Python/C API. never used PyBank before, but I know you're going to move to it for binding stuff, right? well... I can keep working on python-mafw using codegen too.. there's no need to migrate all bindings to the new method. > Please keep us informed of your progress here in the list :) Keep up > the good work! just learning and doing as much as I can :) Thanks again for you help! -- Andrea Grandi email: a.grandi [AT] gmail [DOT] com website: http://www.andreagrandi.it PGP Key: http://www.andreagrandi.it/pgp_key.asc
- Previous message: [pymaemo] How to add PyModule_AddObject to the override file?
- Next message: [pymaemo] How to add PyModule_AddObject to the override file?
- Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]