[maemo-developers] Kismet on N810 with Latest Maemo Diablo with Latest Updates

From: Mr M redpenguinmail at gmail.com
Date: Mon Nov 23 10:29:30 EET 2009
Update to previous email:

Kismet will not run properly again until device is rebooted.

What can cause this?

On Sun, Nov 22, 2009 at 10:34 PM, Mr M <redpenguinmail at gmail.com> wrote:
> 3 hour mark?
> Is there something with the power settings on the Maemo?
> I noticed that once Kismet hits about 3 hours 15 minutes it just stops
> receiving anything packet wise even though once it went to overnight.
> Twice it stopped at 3 hr and almost 15.
> Is it wlan0's power options that iwconfig wlan0 power off should fix?
> On Sun, Nov 22, 2009 at 5:23 PM, Mr M <redpenguinmail at gmail.com> wrote:
>> I finally got it working well.
>> I found a 2009 version of Kismet from
>> http://matt.ucc.asn.au/kismet-maemo/ and it works so well, it actually
>> while only using battery after even using the device for a half hour
>> on the Internet to talk via GTalk, actually captured packets for 3
>> hours 13 min NO TIMEOUT.
>> Then while plugged in, it worked from 3AM until 1PM, probably could
>> have continued but didn't want to fill disk up and no real need to run
>> it that long except to make sure it doesn't timeout.
>> Thank you so much Matt, for providing Maemo users with such a great
>> program, which IMHO just seems to go excellent with the device,
>> especially being it runs Linux and has a WiFi card, pretty much the
>> only 2 major requirements.
>> On Fri, Nov 20, 2009 at 1:08 PM, Mr M <redpenguinmail at gmail.com> wrote:
>>> I was searching Google and various Maemo sites for Kismet and I found
>>> that the 2008 version of Kismet .deb works fine for the most part on
>>> my N810 yet after a while Kismet just times out, it says "Saving Data
>>> Files" with but it stops receiving any packets but elapsed time keeps
>>> going.
>>> I have to restart Kismet, sometimes it lasts over 1 hour 15 minutes
>>> still working but sometimes it only lasts 25 minutes.
>>> I tried various techniques including connecting to a WiFi access point
>>> first and even turning off Power Saving for that connection then
>>> starting Kismet.
>>> I even tried iwconfig wlan0 power off to attempt to turn Power Saving
>>> off before starting Kismet.
>>> All the posts and results I found on the Internet have resulted in old
>>> posts from early 2007 to mid 2008, that often talks strictly about the
>>> N770 and N800 and often talk about OS 2007.
More information about the maemo-developers mailing list