[maemo-developers] Problems with extras-devel repository on N900 ("No Hash entry in Release file")

From: Kate Alhola kate.alhola at nokia.com
Date: Mon Nov 30 16:51:46 EET 2009
ext Anderson Lizardo wrote:
> Hi,
> I've noticed a problem with extras-devel repository. Its Release file
> is missing the hashes for the indexes files. Compare this (broken)
> Release file:
> http://repository.maemo.org/extras-devel/dists/fremantle/Release
> with the one from extras:
> http://repository.maemo.org/extras/dists/fremantle/Release
> or even from Diablo extras-devel:
> http://repository.maemo.org/extras-devel/dists/diablo/Release
> Because of this, "apt-get update" is failing to update the
> extras-devel indexes on N900, with the following error:
> W: Failed to fetch
> http://repository.maemo.org/extras-devel/dists/fremantle/Release  No
> Hash entry in Release file
> /var/lib/apt/lists/repository.maemo.org_extras-devel_dists_fremantle_Release
> E: Some index files failed to download, they have been ignored, or old
> ones used instead.
> This means that extras-devel packages cannot be currently installed on the N900.
> Strangely, this problem only happens on the N900. Scratchbox seems
> happy with the incomplete Release file (probably the apt-get version
> in Scratchbox ignore the error).
> Can someone confirm this on N900? If so, I'll open a bug report about it.
I can confirm it. I tried today with several devices. This
bug has some random nature. One hour ago, I was able to get
extras-devel but now I tried again and got same bug.


More information about the maemo-developers mailing list