[maemo-developers] Getting package with lower version into extras-testing

From: Cornelius Hald hald at icandy.de
Date: Wed Oct 14 00:19:59 EEST 2009
On Tue, 2009-10-13 at 22:38 +0200, Jeremiah Foster wrote:
> I strongly second Graham's point of view on this. Changing anything in  
> the build system has a ripple effect on all packages and we can't  
> afford a complete set of repository rebuilds at this point in time.  
> Hopefully conforming to the current requirements of the build system,  
> i.e. packages with a newer version get built, older packages do not,  
> is not too burdensome.

Ok I did this now. I have conboy-0.5.x now and conboy-unstable-0.6.x.
Unfortunately I still cannot get the updated 0.5.x package into
extras-testing as the promotion still does not work with the higher
epoch. I filed a bug here [1].

I don't know how long it will take to fix this and I could understand if
it gets a low priority, because only me depends on it now. To resolve
this issue quickly I only see two options:

1) I do a new package with higher epoch and higher version number. That
would mean converting 1:0.5.7 into 2:0.6.0 (or something bigger than
0.6.0). I don't really like this, because it makes no sense from a
versioning point of view.

2) Someone deletes all conboy packages with version >= 0.5.6 (including
all of 0.6.x) from extras-devel. If this would be possible I could
remove all the crap I since tried (like increasing the epoch etc.) and
just upload fresh working packages. This would only affect extras-devel.
All other repositories need no change.

If you (Jeremiah) or Niels or someone how has the power could do that I
would be really really grateful. I really screwed that up - so sorry for
the work I create.


[1] https://bugs.maemo.org/show_bug.cgi?id=5416

P.S. There might be other options of course, or maybe fixing the bug is
a quick thing. So I'm also happy about other input which might resolve
this situation.

More information about the maemo-developers mailing list