[maemo-developers] can't install application to phone from local repository

From: daniel wilms daniel.wilms at nokia.com
Date: Thu Oct 22 16:36:24 EEST 2009

Marius is right, it is because of the wrong section. If you enable the 
red-pill mode [1] and select in the settings "show all packages" then it 
should work. Packages, which are not in the user section, are assumed as 
system packages and are only installed by the AM if they are 
dependencies of "user"-packages. This is the reason for the error 
message you saw. So change the section, or follow the steps described 
above and it should work.


Cheers Daniel

ext Aniello Del Sorbo wrote:
> 2009/10/22 Marius Gedminas <marius at pov.lt>:
>> On Thu, Oct 22, 2009 at 02:04:38PM +0200, ibrahim wrote:
>>>     Package: hello
>> ...
>>>     Section: base
>> ...
>>>  but the Application manager says that it couldn't download the
>>> application : "unable to download 'hello'. Application package not found".
>> The Application Manager lets the user install only those packages that
>> are in sections starting with "user/".  It installs packages from other
>> sections only as dependencies for user/* packages.
>> The list of supported sections is in the wiki:
>> http://wiki.maemo.org/Maemo_packaging#Sections
>> HTH,
>> Marius Gedminas
> I thought of the very same reason.
> But then the error should be different than "unable to download" or
> "package not found".
> It should actually not even start the installation process and simply
> state "Uninstallable"
> like when a dependency is missing.
> --
> anidel
> Sent from London, Eng, United Kingdom
> _______________________________________________
> maemo-developers mailing list
> maemo-developers at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-developers

More information about the maemo-developers mailing list