<HTML><HEAD><TITLE></TITLE><style type = "text/css"><!-- body { font-family:"Sans"  } --> </style><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8"></HEAD><BODY><font face="Sans" size=3>Hallo Jakub,<BR>
<BR>
i am on the highway leading south so i could not connect to maemo.org, so can you send me the correct StartupWMClass command?<BR>
<BR>
br Mathias</font><font face="Sans" size=3><BR>
----- Urspr√ľngliche Mitteilung -----<BR>
Von: &lt;<a href="mailto:Jakub.Pavelek@nokia.com">Jakub.Pavelek@nokia.com</a>&gt;<BR>
An: &lt;<a href="mailto:m.uebelacker@googlemail.com">m.uebelacker@googlemail.com</a>&gt;, &lt;<a href="mailto:maemo-developers@maemo.org">maemo-developers@maemo.org</a>&gt;<BR>
Gesendet: Fr., 19. Jan. 2007 13:27:22 CET<BR>
Betreff: RE: [maemo-developers] starting python application without buildingpackage<BR>
Hi,<BR>
 <BR>
you do not need to have the service file for such simple testing. Just<BR>
make sure to point the Exec to the application and then set the<BR>
StartupWMClass to the window name (helps to keep it alive).<BR>
 <BR>
Posting the full contents of the .desktop file also helps finding the<BR>
problem;)<BR>
 <BR>
--jakub<BR>
<BR>
<BR>
        Hallo erverybody,<BR>
        <BR>
        i would like to try my application on the device without<BR>
building a package.<BR>
        <BR>
        So i create a .desktop file with<BR>
        <BR>
        EXEC=/home/user/Python/timetracker.py<BR>
        <BR>
        an a .service file with the same link.<BR>
        <BR>
        By clicking the entry in the navigationbar i get a info banner<BR>
with...timetracker will be load... but nothing more.<BR>
        <BR>
        1. Is there a mistake in the EXEC command?<BR>
        <BR>
        2. In xterm i use the run-standalone command to start the<BR>
application in front of the theme. Is it possible to use this command in<BR>
the .desktop file?<BR>
        <BR>
        br<BR>
        Mathias <BR>
<BR>
</font><BR>
<BR>
</BODY></HTML>