[maemo-users] [maemo-users] Input/Output error from memory card

From: Guido Flohr guido at imperia.net
Date: Fri Jan 6 23:39:33 EET 2006
Hash: SHA1


I can't use the memory card.  When I create a new directory on the
memory card, or copy a file to it, the operation will soon fail with
"input/output error". With "soon" I mean, that creating directories will
fail most of the times, and copying data will fail sooner or later, but
not after a constant amount of data copied.

In any case, directories or files created on the memory card will vanish
~ (really!) after a short grace (< 60 s) period.

It doesn't matter how I try to create files/directories on the card.  I
have tried over the GUI, with the shell and also via USB (from Linux and
Windows XP).  The behavior is always the same.

When I access the memory card via USB, the icon will remain
disabled/insensitive even after I disconnect the device.  I have to
reboot the device to get the icon enabled again.

I have two memory cards, on 64 MB that shipped with the Nokia 770, and
another one of 256 MB that I had ordered along with the device from
Nokia.  Same error with both cards.

On my Linux box, the error shows up in the syslog:

Jan  6 21:25:26 guidomobil kernel: sda: Current: sense key: Medium Error
Jan  6 21:25:26 guidomobil kernel:     Additional sense: Unrecovered
read error
Jan  6 21:25:26 guidomobil kernel: Info fld=0x0
Jan  6 21:25:26 guidomobil kernel: end_request: I/O error, dev sda, sector 0
Jan  6 21:25:26 guidomobil kernel: SCSI error : <0 0 0 0> return code =

The error messages are repeated with "sector 0" counting up to 8, 16,
24, 32, etc.

Any ideas?

- --
Imperia AG, Development
Leyboldstr. 10 - D-50354 Hürth - http://www.imperia.net/
Version: GnuPG v1.4.0 (GNU/Linux)


More information about the maemo-users mailing list