[maemo-users] [maemo-users] Please Help-power-on/boot issue

From: Igor Stoppa igor.stoppa at nokia.com
Date: Mon Oct 23 22:50:21 EEST 2006
On Mon, 2006-10-23 at 15:32 -0400, ext Michael Wiktowy wrote:
> On 10/23/06, Doug Frazee <dougfrazee at yahoo.com> wrote:
>         My 770 is only a couple of months old.  It is primarily a
>         touchscreen remote control for my squeezebox.  After sitting
>         for a couple of days (off the charger with cover on) it would
>         not turn-on.  After plugging it into the charger, the screen
>         came to life with the Nokia logo then the dimmed and displayed
>         a charging icon.  Some time later, it displayed battery full.
>         Problem is the unit will still not power-on,  No white screen
>         no vertical bars, simply no sign of life whatsoever.  I'd
>         consider it hopelessly bricked, except all seems fine when I
>         plug it into the charger.  
>         I tried :
>         removing/reinstalling the battery
>         removing the battery & waiting 2+ minutes prior to
>         reinstalling
>         turning the device on while connected to the charger
>         measured battery voltage, iirc ~4.2VDC 
>         In summary, nothing works.  The unit shows absolutely no signs
>         of life when off the charger.  Although the display lights and
>         it appears fine when connected to the charger, it will not
>         turn-on even when plugged-in.  I contacted Nokia and received
>         authorization to send it to their Texas repair facility.  
>         I'd love to get it running again without sending it in.  Can
>         anyone help?
> Hi Doug,
> I've had this sort of thing happen when I've let the bettery run
> completely dry when first getting it. Make sure that your battery is
> all charged up and the try pressing and holding the power on button
> for a long, long time. If you think that you have waited long enough,
> wait another minute and then release the button and then give it a
> quick press and release. Also, release the button if it starts to
> boot. If that doesn't work try this when the charger is plugged in. 
> That worked for me. I haven't let the battery run dry since and I
> haven't had any problems.
> /Mike

the charger itself is a wakeup source, no need to press buttons.  The
presence of power from the charger is enough.

About this specific problem, Doug, any chance of trying to boot it with
another battery?


Igor Stoppa (Nokia M - OSSO / Tampere)

More information about the maemo-users mailing list