[maemo-users] [maemo-users] Please Help-power-on/boot issue

From: Doug Frazee dougfrazee at yahoo.com
Date: Mon Oct 23 23:28:31 EEST 2006
Thanks Mike, 
I brought the 770 in to work today, boxed-up ready to send.  I cracked the box open and tried your suggestion but unfortunately, it didn't turn-on.  After the initial issue, the recharge took over an hour, before battery full was indicated.  Subsequent attempts to top-off the battery take only minutes to get to the battery full text.  And the battery measures over 3.7VDC.  I know that the battery could still be hosed, but it appears that this is not the case.

Thanks for your suggestion, I won't send the unit in 'til tomorrow and I'll try any other suggestions that roll-in.


Michael Wiktowy <michael.wiktowy at gmail.com> wrote: On 10/23/06, Doug Frazee <dougfrazee at yahoo.com> wrote: My 770 is only a couple of months old.  It is primarily a touchscreen remote control for my squeezebox.  After sitting for a couple of days (off the charger with cover on) it would not turn-on.  After plugging it into the charger, the screen came to life with the Nokia logo then the dimmed and displayed a charging icon.  Some time later, it displayed battery full.  Problem is the unit will still not power-on,  No white screen no vertical bars, simply no sign of life whatsoever.  I'd consider it hopelessly bricked, except all seems fine when I plug it into the charger.  

I tried :
removing/reinstalling the battery
 removing the battery & waiting 2+ minutes prior to reinstalling
turning the device on while connected to the charger
measured battery voltage,  iirc ~4.2VDC 

In summary, nothing works.  The unit shows absolutely no signs of life when off the charger.  Although the display lights and it appears fine when connected to the charger, it will not turn-on even when plugged-in.  I contacted Nokia and received authorization to send it to their Texas repair facility.  

I'd love to get it running again without sending it in.  Can anyone help? 

Hi Doug,

I've had this sort of thing happen when I've let the bettery run completely dry when first getting it. Make sure that your battery is all charged up and the try pressing and holding the power on button for a long, long time. If you think that you have waited long enough, wait another minute and then release the button and then give it a quick press and release. Also, release the button if it starts to boot. If that doesn't work try this when the charger is plugged in. 

That worked for me. I  haven't let the battery run dry since and I haven't had any problems.


Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1¢/min.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-users/attachments/20061023/27265dec/attachment.htm 
More information about the maemo-users mailing list