[maemo-users] [maemo-users] nokia 770 modem problems after upgrading to maemo 2006

From: werner stadler wvrn at wvrn.cc
Date: Sat Oct 28 10:58:22 EEST 2006
after upgrading my nokia 770 from the (original) 2005 maemo i can't get
my nokia n70 working as a umts-modem again. i took a "backup" of the old
maemo with rsync. here is the story:
1) paired the two devices (n70 and 770). the n70's filebrowsing on the
770 worked.
2) set up the connection (connection manager): there is a preconfigured
setting for my provider "drei.at"
3) when i try to connect, the telephone responses something like "do you
want to authorise the connection setup.." (i can change the phone's
setting to "always authorise", then there is no message)
4) after a few seconds the message "connection failed...try again?"
appears on the nokia 770

5) steps to solve the problem
5.I) checking the provider's settings: 
- *99# (recommended by the hotline and some internet sites) instead of
*99***1# (preconfigured setting on the nokia 770)
- empty passwd, login
- additional AT-commands: AT+CGDCONT=1,"IP","drei.at" (should not be
i tested it with some variations of the AT-commands above, and with
empty AT-command (preconfigured setting)
5.II) getting the old settings out of my rsync-maemo-"backup"
5.II.1) i can't find the old dialup-settings anywhere :-(( - don't know
where these usersettings are stored in maemo (nor in home/.. etc/.. ...
grep couldn't find the string "drei.at")
5.III) ppp and bluetooth settings
i compaired the old and new ppp and bluetooth-settings with diff - there
was nothing noteable, then i (..hack..) just mv'd the new etc/ppp and
etc/bluetooth dir's to x_2006 and rsynced back the old settings. this
didn't change anything.

5.IV) downgrade to the old maemo-version :-(((((((((((((((((((
in short: i tried to flash (using flash_2.0, flash, and the new
windows-flasher) to an old .bin. maybe i should use the option
"cold-flash" or something else i don't dare to. (does anyone know how a
downgrade works?)

6. the main problem seems to be: how can i get a serious debug-output on
the 770 terminal to see how far the connection setup comes to locate the

please someone help me.. the last year was a good one, because my 770
worked so fine together with my n70. 

ps: _never_ change a running system..

More information about the maemo-users mailing list