[maemo-users] Proxy settings

From: Sascha Feldhorst sascha.feldhorst at udo.edu
Date: Sun Dec 2 14:02:45 EET 2007
thanks for the suggestion, but when I tried it out the result was same as 
before (using the graphical packet manager). So I tried to do an manual 
update of the packet database using "apt-get update" in a root shell. The 
packet fetch worked here, but unfortunately the signature test (gpgp) failed 
due to a bad signature (BADSIG CBFC2BECC6903E72). 

But now to the interessting part; I configured my firewall to allow direct 
outbounding connections from my N800 and deactivated the proxy settings in 
the connection settings, but leaved the host name and the port number set. 
Afterwards the graphical packet manager still complained, that my proxy needs 
authentification !? So there seems a bug in the logic, that retrieves the 
proxy settings. To solve this I had to clear the proxy host field in the 
connection settings. Afterwards the  packet database was successfully 
updated. But I didn't gave up at this point and reactivated the proxy 
settings and inserted the following line in the proxy host field:

username:password at proxyhost

This worked for the graphical packet manager, but unfortunately not for my 
browser. It complains about malformed urls since then.

So there is still no configuration, that allows me to use a proxy with 
authentification :-(

Best regards

On Saturday 01 December 2007 18:27:57 Eric Cooper wrote:
> On Sat, Dec 01, 2007 at 05:27:56PM +0100, Sascha Feldhorst wrote:
> > Unfortunately the packet manager seems to have problems with the
> > proxy authentification. For example updating the packet list
> > fails. In the protocol the following error message could be found:
> > ...
> > E:Failed to fetch
> > http://www.fbreader.org/maemo/dist/bora/user/binary-armel/Packages.gz 407
> > Proxy Authentification Required
> > ...
> >
> > I found out, that apt respects the following environment variables
> >  * http_proxy
> >  * https_proxy
> >  * ftp_proxy
> >
> > I tried to handle this error by setting this variables in my
> > /etc/profile, e.g.
> > http_proxy="http://<proxy user:proxy passwd>@<proxy address>:<proxy port>
> >
> > With no sucess, even after a reboot.
> I think that using
>     export http_proxy="..."
> in /etc/profile should work. But if it doesn't, you can edit
> /etc/apt/apt.conf, and add the line
>     APT::Acquire::http::Proxy "...";
> (or add it as a separate file, like /etc/apt/apt.conf.d/99proxy )
> Check out the man page for apt.conf on a Debian or Ubuntu system for
> details.

Cand. Inform. Sascha Feldhorst
Universität Dortmund
Mail: sascha.feldhorst at udo.edu
GPG Key ID: 0x1E9E26B5
Key @ Keyserver http://subkeys.pgp.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20071202/0e8f5bdd/attachment.pgp 
More information about the maemo-users mailing list