[maemo-users] help!? my N810 seems dead(ish)

From: Peter Flynn peter at silmaril.ie
Date: Tue Dec 18 03:56:43 EET 2007
Joshua Layne wrote:
> I have contacted Nokia support on this, but I am hoping one of you might be
> able to help me out, if there is a magic incantation or button sequence or
> battery removal and wait that might fix it.
> Basically, my Nokia had a low battery yesterday (I got the warning: "Your
> battery is low" or somesuch).  I plugged it in to the provided wall charger
> and didn't look at it until this morning.  This morning it was dead and
> would not power on or register that it was plugged in (no green LED, no
> "disconnect the charger" notice).  I got in my car and plugged in a (brand
> name) Nokia car charger and the device registered the charge and I was able
> to power on the device.  I ran maemo mapper with GPS running on my way to
> work with no problem (30 minutes or so).  Disconnected the car charger and
> took it up to my desk, where I powered it off (using the power button menu)
> and plugged it in with the wall charger (I brought it into work today).  It
> registered that it was charging (green led, little charging battery icon)
> and I let it sit for over two hours.  I noticed that instead of the usual
> "unplug the charger" notice, it had flashed up the Nokia splash screen
> (blue "Nokia" on white background - no status bar) then the backlight shut
> off, and then the display entirely shut off.
> I then tried a few combinations of things, including plugging/unplugging
> the N810 (wall charger still), taking the battery out for a bit and putting
> it back in.  No love.
> I have gotten the nokia splash screen a few times, but it again shuts down
> the backlight almost immediately and then the screen shuts of a little
> after that.
> Any thoughts for troubleshooting this?  Do I just have a bad unit?  I would
> hate to send this in for repair when it is something I can easily fix on my
> own (or worse, if it won't even show the problem for a repair tech...)

I have the identical problem, and some poking around revealed that the 
wire from the charger to the unit is internally broken close to (or 
within) the rat-tail that comes out of the charger plug.

These chargers seem to be very fragile, which is disappointing for 
something that cannot be replaced easily (not in stores), and the 
closest (N95 charger) costs €25.  They also cannot be opened for a 
simple rewiring repair, even after removing the two retaining screws, as 
they appear to be sealed.

How do I buy a replacement charger (or 3 or 4 of them if they are fragile)?


More information about the maemo-users mailing list