[maemo-users] [maemo-users] A scary story with a happy ending

From: Marius Gedminas marius at pov.lt
Date: Wed Jan 24 10:25:31 EET 2007
Yesterday I installed a couple of games into my 770.  And one of the
games didn't fit--I've filled up the partition.  Scary things started
happening--the user interface became very nonresponsive, I couldn't
switch between tasks, I couldn't open the task menu, I couldn't tap on
the globe icon.  I could switch to the desktop, but it wouldn't even
display my wallpaper--instead I got a white background and a dialog
saying "memory full, free some memory".

I had File Manager open.  I could finally switch to it somehow.  I tried
to delete something, and got an error ("Unable to complete operation").
Uh oh.

Finally I noticed that the user interface was becoming responsive again.
I could go online and ssh into my 770.  I still could not delete any

  $ rm filename
  rm: filename: No space left on device

dmesg was full of kernel messages about the JFFS2 garbage collector
being unable to find any free space.  Uh oh.

I made backups and prepared for reflashing.

I rebooted. Opened up xterm, tried to delete a file.  I could do it!
Then df showed me I had 11 megs freespace.  The garbage collector must
have worked better after a fresh boot.


  * don't fill up your flash, or you'll be sorry
  * I need more disk space, as usual
  * the user interface was unresponsive because the 770 was very busy
    writing to flash (or running the garbage collector), not because it
    was out of disk space

I reflashed anyway, since it was way past time for me to upgrade to OS 2006.2.
I've written up a page with instructions for myself to make the
backup/restore less painful after a reflash:

The most interesting bit is probably the single-click install file for
OpenSSH.  Although you do need to set the application manager into
red-pill mode to use it.

Marius Gedminas
Q:      Why do mountain climbers rope themselves together?
A:      To prevent the sensible ones from going home.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20070124/e57a62d1/attachment.pgp 
More information about the maemo-users mailing list