[maemo-users] [maemo-users] A scary story with a happy ending

From: Eero Tamminen eero.tamminen at nokia.com
Date: Wed Jan 24 11:19:12 EET 2007

ext Marius Gedminas wrote:
> Yesterday I installed a couple of games into my 770.  And one of the
> games didn't fit--I've filled up the partition.  Scary things started
> happening--the user interface became very nonresponsive, I couldn't
> switch between tasks, I couldn't open the task menu, I couldn't tap on
> the globe icon.  I could switch to the desktop, but it wouldn't even
> display my wallpaper--instead I got a white background and a dialog
> saying "memory full, free some memory".
> I had File Manager open.  I could finally switch to it somehow.  I tried
> to delete something, and got an error ("Unable to complete operation").
> Uh oh.
> Finally I noticed that the user interface was becoming responsive again.
> I could go online and ssh into my 770.  I still could not delete any
> files:
>   $ rm filename
>   rm: filename: No space left on device

Normal user shouldn't be able to fill the device rootfs this full,
only root should be able to do that.  And Application installer
(which runs dpkg as root) should handle the case of installed
package not fitting on the device.  It's possible that the packager
has botched the package and it creates at installation files that
won't be removed when the package install is canceled.  This is the
worst bug a package can have on a devices with limited disk space,
on par with making Desktop to continuously crash.

Had you any extra packages installed which might be running as root
and e.g. logging things onto Flash?

> dmesg was full of kernel messages about the JFFS2 garbage collector
> being unable to find any free space.  Uh oh.
> I made backups and prepared for reflashing.
> I rebooted. Opened up xterm, tried to delete a file.  I could do it!
> Then df showed me I had 11 megs freespace.  The garbage collector must
> have worked better after a fresh boot.
> Moral:
>   * don't fill up your flash, or you'll be sorry
>   * I need more disk space, as usual
>   * the user interface was unresponsive because the 770 was very busy
>     writing to flash (or running the garbage collector), not because it
>     was out of disk space

There's no free space until files been both removed *and* garbage
collected by JFFS2.  Some N770 users have also encountered the problem
where the device enters reboot loop because the garbage collection
on the device bootup triggers the device HW watchdog.

If you encounter this again, I would recommend backing up any important
information before reboot if you can, just in case.  (besides reporting
it here...)

> I reflashed anyway, since it was way past time for me to upgrade to OS 2006.2.
> I've written up a page with instructions for myself to make the
> backup/restore less painful after a reflash:
> http://mg.pov.lt/770/reflash.html
> The most interesting bit is probably the single-click install file for
> OpenSSH.  Although you do need to set the application manager into
> red-pill mode to use it.

	- Eero

More information about the maemo-users mailing list