[maemo-users] Issues with package installation and failed dependencies

From: Marius Vollmer marius.vollmer at nokia.com
Date: Mon Jul 9 10:37:26 EEST 2007
"ext Mike Klein" <mklein at vxappliance.com> writes:

> How is it that a package can be marked "Installable" and yet not install?

A package has status "Installable" when there are no dependency issues
upfront (i.e., no missing packages and no unresolvable conflicts).  A
package might still fail to install, tho: it might contain files that
are also in some other package, or one of its maintainer scripts might
fail (or you might run out of storage, etc).

> With new firmware I cannot "cleanly" install unzip, wget...as these have
> bizarre dependency issues.
> With wget I get dep failure of "wget-ssl" conflict...yet I have no wget
> on N800 and from googling this appears to be a deprecated package.

The Application Manager is not smart at all when reporting conflicts.
It might be that the AM picks out wget-ssl as the culprit although it
is not installed.  This is probably technically correct, but not very
helpful.  In general, if you have bizzare dependency issues, debugging
them with the AM is going to be hard.  You pretty much have to dig
into the issue using apt-cache, et al.  (I have plans to get more
serious about reporting conflicts in the AM.)

The idea is of course that the repositories don't contain bizarre
dependency issues.  But with our bizarre repository landscape, bizarre
dependencies are unfortunately to be expected.

> I also tried installing a gstreamer plugins lib (said it was
> installable) and it fails silently! Wtf?!? This is linux man. Error
> msgs please. There are ZERO dep issues for this pkg and it just
> fails.

Error messages are in "Tools > Log".

Again, the idea is that the maintainer of a package (together with the
maintainers of related packages) makes sure that it installs properly
before it hits Joe Sixpack.  For Joe, "Unable to install foo" should
just mean "Foo is broken, gaad dammit, let's try Bar."  He is not
supposed to be able to do anything about it.

Likewise with missing dependencies: In the normal world, getting a
package that has a missing depencies means that the distribution you
are using is broken and there is not much more you should do than file
a bug and wait.  In the maemo world, people go on a package hunt to
find the missing pieces somewhere in one of the million repositories.
No wonder it gets messy.

> I am in redpill mode as I needed root access for a variety of apps.

(Red-pill mode has nothing to do with root access.  It only controls
what packages you see in the Application Manager.)

More information about the maemo-users mailing list