[maemo-users] RTCom - SIP Service

From: Larry Battraw lbattraw at gmail.com
Date: Fri Jul 20 15:27:46 EEST 2007
On 7/20/07, Marius Vollmer <marius.vollmer at nokia.com> wrote:
> "ext Larry Battraw" <lbattraw at gmail.com> writes:
> >   As an aside, has anyone had their Application manager break after
> > trying to to install RTCom?  I managed to get RTCom installed manually
> > via apt-get/dpkg but now whenever I run the Application manager the
> > window will appear almost instantly, titled "Application manager", and
> > sit forever.
> That usually means that the backend process does not start up and the
> frontend is waiting for it to respond.  That's quite bad since you
> basically can't debug the situation without help from the frontend.
> It's a known bug that has been fixed in more recent versions of the
> AM.

  Are these versions available in Sardine or somewhere else?

> The backend has quite low requirements for a successful startup.
> Usually, sudo has some problems.  Try this as "user":
>     $ sudo /usr/libexec/apt-worker
>     apt-worker: wrong invocation
> If you see the error message "wrong invocation" from apt-worker, it
> has been started successfully.

  Yep, that is exactly what it printed, so no problem with the
/etc/sudoers file; I verified that by hand as well.
-r--r-----    1 root     root         2316 Jul 19 09:02 /etc/sudoers

> > Doing a strace results in the attached log
> Thanks for the strace!  It was only for maemo-invoker and not for the
> hildon-application-manager, but I appreciate the effort! :-) Debugging
> can be a bitch on the maemo platform... :)

  Sigh....  :-)  I figured it was awfully short for what was getting
kicked off.   I did a copy of the root FS to the internal SD card to
boot from and now it works for whatever reason, regardless of whether
I boot from flash or SD.  Very strange.  I had already tried rebooting
before so I'm unsure of what has changed.


More information about the maemo-users mailing list