[maemo-users] Quick Launch for simple scripts

From: Julian Toler juliantoler at googlemail.com
Date: Fri Jan 4 11:45:55 EET 2008
I tried to install osso-statusbar-cpu (from the list of installable apps in
my Application Manager) but it tells me I have an incompatible package -

I found the following command to tell me about the dependencies: apt-cache
show, so I ran this and it gave me the following:

Nokia-N800-44-4:~# apt-cache show hildon-libs0
Package: hildon-libs0
Priority: optional
Section: libs
Installed-Size: 380
Maintainer: Michael Dominic Kostrzewa <michael.kostrzewa at nokia.com>
Architecture: armel
Source: hildon-libs
Version: 0.14.11-1
Replaces: hildon-lgpl0 (<< 0.12)
Depends: libatk1.0-0 (>= 1.9.0), libaudiofile0 (>= 0.2.3-4), libc6 (>=
2.3.5-1), libdbus-1-2 (>= 0.61), libdbus-glib-1-2 (>= 0.61), libgconf2-6 (>=, libglib2.0-0 (>= 2.8.6-1osso1), libgtk2.0-0 (>= 2:2.6.10-1.osso8),
libmatchbox1 (>= 1.7-1), libpango1.0-0 (>= 1.8.1), libpng12-0 (>= 1.2.8rel),
libx11-6, libxext6, osso-esd, osso-sounds-ui, hildon-libs-l10n-mr0 |
Conflicts: hildon-lgpl0 (<< 0.12)
Filename: pool/maemo3.2/free/binary/hildon-libs0_0.14.11-1_armel.deb
Size: 171622
MD5sum: 348c9e6a2b7af6fe49fea3e0398cd715
Description: Hildon libraries

It looks like this Hildon library is pretty much required for a whole load
of things - but is this dependency list a global dependency list or
specifically for my software setup? How can I work out what needs
hildon-libs0 on my machine?

Or maybe I have an old version of the library and this is what has been
detected and giving me a problem - I am just in the dark about this with
limited experience telling me where to go next.

If anyone can suggest a way to get osso-statusbar-cpu working I would
appreciate it!

My N800 has a set of what I would think are common apps installed:
Maemo Mapper
Maemo screengrabber
Password Safe
Crazy Parking
Maemopad +
VNC Viewer
All these are working perfectly.


On 03/01/2008, sebastian maemo <sebastian.maemo at gmail.com> wrote:
> Hi, great news :)
> I found a terribly easy solution...
> osso-statusbar-cpu
> It can be found at the following repositories:
> deb http://maemo-hackers.org/apt/ mistral main
> deb http://maemo-hackers.org/apt/ bora main
> Besides giving CPU/Mem information, it CAN run commands, AND you can add
> items to the list of predefined commands... So that you can run any script
> you like just specifying the command like: "/bin/sh <
> /home/user/your_script"... (And no need to type it each time)
> Wow, thank you Santtu Lakkala!
> Salut,
> Sebas.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-users/attachments/20080104/ee4f2b92/attachment.htm 
More information about the maemo-users mailing list