[maemo-users] WPA PEAP MSCHAPV2 wifi net access not working

From: Joshua Layne joshua at willowisp.net
Date: Sat Jan 5 19:48:28 EET 2008
Nuno Faria wrote:
> Hi Joshua,
> thank you for your help. I'm sorry I hadn't found your previous post reporting this bug.
> Btw, I'm using v. 2.2007.50-2. I tried your sugestion but I got the same result. The system keeps asking me for the wep key and fails to get the IP add. It is not easy for me to get access to the AP logs, but I will try.
Is it really asking you for the _WEP_ key?  That doesn't seem right, 
given your information below.

If my post wasn't clear enough, I can experiment with maemo-screenshot 
and see if I can put together a pictorial howto.

> Meanwhile I will add this information to the bug discussion.
> Nuno
> ----- Original message -----
> From: Joshua Layne <joshua at willowisp.net>
> To: maemo-users at maemo.org
> Sent: Sat,  5 Jan 2008, 01:18:33 WET
> Subject: Re: WPA PEAP MSCHAPV2 wifi net access not working
> nfaria at fe.up.pt wrote:
>> Hi,
>> I've just bought a N810 (what a great machine, exactly what I needed and
>> wanted...).
>> I've been trying to connect to my office wifi network but it is not
>> working.
>> Would someone, please, give me a clue to what may be happening?
>> Here is a description of the problem:
>> The network APs (CISCO) are configured to answer to a PEAP MSCHAPv2
>> access request. I configured wpa_supplicant on my linux laptop and it
>> works. On the N810, it detects the network, starts the access proccess,
>> but then asks for the WEP key (I have no other key besides the
>> password).
>> When I re-enter the password (it had been previously defined on the
>> config file), the connection aborts with the message that it could not
>> retrieve the IP address and suggests that the WEP key may be wrong.
>> I have checked the password several times over!
>> Thanks,
>> Nuno Faria (nfaria at fe.up.pt)
>> PS: Here are the details that may help solving the problem
>> Here is the wpa_supplicant.conf file on the linux laptop:
>> network={
>>        ssid="Biotempo"
>>        scan_ssid=1
>>        key_mgmt=IEEE8021X
>>        eap=PEAP
>>        phase2="auth=MSCHAPV2"
>>        identity="Biotempo"
>>        password="XXXXXXXXXXXXX"
>> }
>> NOTE: Password contains # and $ symbols, besides letter and number
>> characters
>> On the N810, I introduced the following configuration:
>> Connection type: WLAN
>> SSID: Biotempo
>> Network is hidden: yes
>> Network mode: Infrastructure
>> Security method: WPA with EAP
>> EAP type: PEAP
>> Select certificate: None
>> EAP method: EAP MSCHAPv2
>> User name: Biotempo
>> Prompt password at every login: No
>> In Advanced:
>> No proxies
>> Auto-retrieve IP address: yes
>> ...
>> WPA2-only mode: No
>> ...
>> EAP: No to every question
>> ...
> Try entering a manual username (your real username) under the advanced 
> EAP settings - counterintuitive, but that's what worked for me.  Pretty 
> much the same network setup in my office.
> Here is my 'resolved' email: 
> http://lists.maemo.org/pipermail/maemo-users/2007-December/008172.html
> HTH,
> Josh
> _______________________________________________
> maemo-users mailing list
> maemo-users at maemo.org
> https://lists.maemo.org/mailman/listinfo/maemo-users

More information about the maemo-users mailing list