[maemo-users] Hosed 810's internal 2G flash drive...

From: Eero Tamminen eero.tamminen at nokia.com
Date: Mon Jan 21 10:22:07 EET 2008

ext Michael R. Head wrote:
> I've been heavily using my 810 since I got it, and have had a few
> crashes. Recently, I've noticed that the 810's internal 2G drive is now
> readonly. 
> I've tried reflashing the OS with
> RX-44_2008SE_2.2007.50-2_PR_COMBINED_MR0_ARM.bin, but it's still coming
> up read-only.
> I've tried umounting it and running fsck.vfat on it (over ssh), but I
> get a malloc error:
> Nokia-N810-50-2:~# fsck.vfat  /dev/mmcblk0p1 

Fsck unfortunately isn't very bright when it comes to memory usage.
With some file system layouts it can use too much memory.

> dosfsck 2.11, 12 Mar 2005, FAT32, LFN
> alleged total clusters: 999603
> malloc:Input/output error
> I'm now trying to rsync off the map folder, since that's the only data
> on it that I can't recreate so that I can run mkfs.vfat on it and regain
> write access to it.

Just connect the USB cable to the device and fix the FAT from your
desktop computer.

> Unfortunately, I'm not getting anywhere with that,
> either... I'm getting I/O errors during the rsync.
> So I guess my question is this: Is it possible to recreate
> the /media/mmc2/map folder if I do a mkfs on the drive?

	- Eero

More information about the maemo-users mailing list