[maemo-users] Need Some Basic Help

From: Dr. Nicholas Shaw Doc at DocHarley.com
Date: Thu Jul 17 18:53:46 EEST 2008
I have a program (C++) that uses SQLite3 (3.5.9) as the backend DB.  I
decided to move this from SUSE 10.3 where it compiles/runs without any issue
to my Nokia N800 and N810 (should arrive today).  To do that I installed a
VMware guest running Debian 4R3 (latest release) and installed g++.  I then
copied the files (database (fuel.db), source code, header file (for sqlite),
and make) to the new system and compiled it.  If this worked then I was
going to download/install the SDK and test it there.  It compiled without
issue but when I attempted to run it - error.

The error I'm getting is: "error while loading shared libraries:
libsqlite3.so.0: cannot open shared object file: No such file or directory."
The file is located in /usr/local/lib.

The make is a simple script: "g++ -O -ogas -L/usr/libs -L/usr/local/lib
-I/usr/libs -lsqlite3 gas.cpp

I added the /usr/local/lib to correct the problem but without success.  I
also tried adding -I/usr/local/lib without success.  

This is a gas mileage program that, when completed, will eliminate one thing
I need gnumeric for.  It handles miles/litres so basically operates
anywhere, user changeable.  Any recommendations for fixing this? As you can
see, I've tried directory and linker options without success.

Again, everything works fine under SUSE 10.3.  I'm also posting this to a
Debian forum but figured I might as well increase my chances by posting
here. :-)


More information about the maemo-users mailing list