[maemo-users] Need Some Basic Help

From: Dr. Nicholas Shaw Doc at DocHarley.com
Date: Thu Jul 17 21:34:41 EEST 2008
Thanks, David - option 2 did the trick! 

Yes, libsqlite3.so.0 is located in /usr/local/lib but I didn't put it there.
I downloaded the 3.5.9 source from sqlite.org (source code) and
compiled/installed according to the README.  Make install placed it there.

I appreciate your help! I'm running sqlite3 and the sqlite0 file that is
included with Debian 4R3 is release 2.
Many thanks,


-----Original Message-----
From: maemo-users-bounces at maemo.org [mailto:maemo-users-bounces at maemo.org]
On Behalf Of David Greaves
Sent: Thursday, July 17, 2008 10:33
To: Dr. Nicholas Shaw
Cc: maemo-users at maemo.org
Subject: Re: Need Some Basic Help

Dr. Nicholas Shaw wrote:
> I have a program (C++) that uses SQLite3 (3.5.9) as the backend DB.  I
> decided to move this from SUSE 10.3 where it compiles/runs without any
> to my Nokia N800 and N810 (should arrive today).  To do that I installed a
> VMware guest running Debian 4R3 (latest release) and installed g++.  I
> copied the files (database (fuel.db), source code, header file (for
> and make) to the new system and compiled it.  If this worked then I was
> going to download/install the SDK and test it there.  It compiled without
> issue but when I attempted to run it - error.
> The error I'm getting is: "error while loading shared libraries:
> libsqlite3.so.0: cannot open shared object file: No such file or
> The file is located in /usr/local/lib.

I assume you mean libsqlite3.so.0 is located in /usr/local/lib because you
copied it there (is it an ARM version?)

This is a runtime issue.

Two fixes:
1. Preferred. Install sqlite properly: apt-get install libsqlite0

2. OK, you're not going to do that: so dynamic library loading is controlled
/etc/ld.so.conf config file
Add /usr/local/lib to the config file and re-run (as root) ldconfig

Then when your app runs it'll find the dynamically loaded library.

> The make is a simple script: "g++ -O -ogas -L/usr/libs -L/usr/local/lib
> -I/usr/libs -lsqlite3 gas.cpp
> I added the /usr/local/lib to correct the problem but without success.  I
> also tried adding -I/usr/local/lib without success.
Your compile is fine.

maemo-users mailing list
maemo-users at maemo.org

More information about the maemo-users mailing list