[maemo-users] Missing GPS after Diablo upgrade

From: R. G. Newbury newbury at mandamus.org
Date: Fri Jul 18 20:31:32 EEST 2008
I seem to have lost my GPS since I upgraded to Diablo.

Although /dev/pgps exists, /dev/pts/2 does not.

I have tried by using the Control Panel and GPS location. It never gets 
beyond 'searching'....an hour should do!..

I have tried by launching gpsdriver.
I have tried by launching map. I removed and re-installed map. Same result.

Previously, one could start the gpsd daemon by executing 
/usr/libexec/navicore-gpsd-helper in a terminal.

This started gpsd and you could see the NMEA output sentences.

Now executing that returns only " ptty name: /dev/pts/2" and ...nothing 

I have paired and tried my external bluetooth gps. It sticks at 
'Searching' too, although I have found in the past that it is reasonably 
faster than the internal unit in getting a fix.

Has anyone else seen this?

Does anyone have any ideas about what is happening and how to fix it?


More information about the maemo-users mailing list