[maemo-users] Need Some Scratchbox Help

From: Dr. Nicholas Shaw Doc at DocHarley.com
Date: Wed Jul 23 21:58:46 EEST 2008


Did you install the binaries from sqlite.org? If so, which binaries (I
didn't see any binaries for ARM devices)?  If you got sqlite3 from somewhere
else that has precompiled binaries, please share.  I've had to compile from
source on each version of Linux I've run.


Thanks and I appreciate the help!




From: Denis Dimick [mailto:dgdimick at gmail.com] 
Sent: Wednesday, July 23, 2008 11:34
To: Dr. Nicholas Shaw
Cc: Maemo Users
Subject: Re: Need Some Scratchbox Help


If I recall correctly I had GCC installed before I built the toolchain and
everything worked. I also just downloaded sqlite3 and used "dep -i" to
install it, it works fine for me running Diablo.



On Wed, Jul 23, 2008 at 11:29 AM, Dr. Nicholas Shaw <Doc at docharley.com>

Ok, I've installed (via "other Linux" process) scratchbox and ran
"run_me_first.sh".  I've setup the sbox group and user and have run sb-menu.
So I think I'm good to go.  However, I need to compile/install sqlite3 on
the 810 which requires a C++ compiler (I don't think the scratchbox will
help here).   Any recommendations will be greatly appreciated!





From: Dr. Nicholas Shaw [mailto:Doc at DocHarley.com] 
Sent: Tuesday, July 22, 2008 11:35
To: 'Dr. Nicholas Shaw'; 'Maemo Users'
Subject: RE: Need Some Scratchbox Help


Sorry, one last piece of information.  I went to /var/lib/apt/lists and here
are the files relating to scratchbox:


.         Scratchbox.org_debian_dists_maemo4-sdk_Release

.         Scratchbox.org_debian_dists_maemo4-sdk_main_binary-i386_Packages


Again, thanks!




From: maemo-users-bounces at maemo.org [mailto:maemo-users-bounces at maemo.org]
On Behalf Of Dr. Nicholas Shaw
Sent: Tuesday, July 22, 2008 10:32
To: 'Maemo Users'
Subject: Need Some Scratchbox Help


Good morning (where I am anyway) all!


I'm running Debian 4R3.  I went to Maemo.org/developers and downloaded/ran
the scratchbox script according to the INSTALL.TXT.   I'm installing Chinook
as that is the version of 2008 I'm running.  The install file is
"maemo-scratchbox-install_4.0.1.sh.  As root, I ran chmod a+x on the file
then ran it.


It checks for prerequisites and states that everything seems to  be ok.  The
script continues until it gets to "Ign http://scratchbox.org ./ Packages
where I receive an error 404 Not Found.  The script continues until the next
error, "Failed to fetch http://scratchbox.org/debian/./Packages.gz
<http://scratchbox.org/debian/Packages.gz>  404 Not Found" followed by "W:
Couldn't stat source package list http://scratchbox.org ./ Packages
(/var/lib/apt/lists/scratchbox.org_debian_._Packages) - stat (2 No such file
or directory).


The last line recommended trying an alternative installation method.  Ok, so
I chose to install it manually.


After downloading the appropriate files, I followed the instructions
l#AEN39).  As root, I first added "deb http://scratchbox.org/debian ./
<http://scratchbox.org/debian%20./> " to /etc/apt/sources.list.  I then ran
"apt-get update".  All seemed to be ok up to this point.  I then ran apt-get
install on the packages and failed on the same error as when I ran the
install script.


Any help will be greatly appreciated! And, in advance - THANK YOU! 



maemo-users mailing list
maemo-users at maemo.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.maemo.org/pipermail/maemo-users/attachments/20080723/1c61d6cc/attachment.htm 
More information about the maemo-users mailing list