[maemo-users] My Diablo Impressions

From: Peter Bart peter at petertheplumber.net
Date: Tue Sep 9 02:46:46 EEST 2008
Hello All,
	These are simply my impressions (notes) setting up my tablet's after
flashing the latest Diablo image RX-34_DIABLO_4.2008.23-14_PR_MR0.
Please feel free to add your comments, point out obvious (to you)
mistakes, etc. I am an end user that apparently like to live on the
bleeding edge, or so I'm told ;) Hopefully these will help someone. I'm
pretty sure I'm not going back to a previous OS. It occurs to me that
developers have to be fed up with having to package their software again
and again for different OS versions. I'm wondering if Diablo will solve
this as well as now being able to update via the application manager?

	The image would not flash the first time on either device I loaded,
giving me the error:

Write failed after 0 bytes
usb_bulk_write: Resource temporarily unavailable.

	No problem though, without any changes, simply up arrow in the terminal
window and away we went. I have to say the feel of the new software
feels much more polished. Handwriting recognition is much, much better
as well. I like the way the repositories are set up that are included. I
*really don't like that the repositories are not listed for Diablo. See
below for my opinion of one click install. I love the way the software
updates are delivered. I'm afraid that's pretty much where the love ends
for me. Can I say I hate one click? Sorry. I learned to use repositories
some years ago and I by far prefer to manage my software by managing my
repositories. And then you can see from below that most one clicks don't
work for one reason or another. I've found; by trial and lots of error
that I *must* disable any repository added by a one click install
immediately after installing the software or risk inadvertently updating
something I *really* shouldn't. I should note that I must have
inadvertently downloaded something I shouldn't have onto my tablet. So
far the noticed undesirable behavior is that I cannot receive bluetooth
transfers and some of the buttons/status indicators say things they
shouldn't For ex when launching a program the indicator read something
along the lines of ck-application-loading. I just rebooted after
uninstalling the Give application and now they're back to normal. Hmmmm,
maybe a library got pulled in that shouldn't have??? Bluetooth receiving
file transfers still fails after the n800's find each other, the
location to save the file is selected and save is clicked. Any
suggestions would be very much appreciated since that's how I back up my
cell phone address book to the tablets built in Contacts.
	The core apps were installed via app mngr after enabling all repos
installed by flashing. I won't get into those in to much detail, the
repo's are listed. <http://catalogue.tableteer.nokia.com/certified/>
user <http://catalogue.tableteer.nokia.com/non-certified/> user
<http://repository.maemo.org/extras/> free non-free Did I mention I hate
one click? Much rather work with repos. I should at least acknowledge
the ones I use every day. Conspicuous by it's absence is Gnumeric.
That's really a gotta have it application! advanced backlight, evince,
maemo recorder, mplayer, mytube, openssh, rootsh, rsync, 

	On to my notes on the individual applications.

	Camera gets installed from the main repos but it seems to be very
resource hungry. Not much different from my experiences on other OS
versions. It usually locks up my tablet because I have to many other
things running as well. Unusable for me, YMMV.
	Modest works well enough. I don't like having to go through menus to
view my separate accounts so I went back to Claws. Also, there is a
maximum size that you are able to download w/o actually opening the
email and it seems most of what I get is over that limit. That turns
into a pain when Claws will simply download whatever you tell it to.
Account setup can be tricky because if you don't get it right the first
time you can't go back and change some things. For ex. the various means
of authenticating with pop3, some of which my provider uses and some
not. I have to wade through MS instructions and decipher what they
actually mean, so at times it's guess and by golly. In the end Modest
was ditched in favor of Claws.
	Claws works very well, very polished and solid. *Very* configurable, so
much so I can get lost in the menus. for the most part I take the
defaults. I still can't figure out how to select and delete multiple
emails not in the same thread. I can't remember if I actually installed
it from the repo or via one click.
	I tried to install Maemopad+ via one click and from it's maemo garage
page but no luck. Both immediately after flashing and after the first
software update. I really do want to try this but no luck here.
	Xournal installs via one click and it has many more features than
before. I love my Xournal! It has many more options and does things that
I don't even know about. I just use it to scribble notes. Did this used
to have an icon on the toolbar for file open and save? It doesn't
anymore, I miss that.
	Omweather; one of my favorite applets. It too is much more polished and
very easy to use. 
	Leafpad does not install. I want my leafpad :( It's the only editor
that lets me have multiple files open at the same time and saves in a
format any text editor can open! I tried to install the Maemo Garage
version from here
<https://garage.maemo.org/frs/?group_id=712&release_id=1891>, it's not
in any repo that I know about so far.

*Important note* Disable all repositories added after one click!!!!

Htttrack and webhhtrack one click install fails. unable to download
xxxxx application package not found.

Gutenbrowse one click install fails. Installs
http://www.elisanet.fi/ptvirtan/repo/, main component but not the
distribution. Manually edit to say chinook works then install from app
mngr. Installs/activates fbreader repo ok. I used red pill to install
the required python 2.5 runtime.

Xgalaga one click install fails. unable to download xxxxx application
package not found.

Moonlander one click install fails. unable to download xxxxx application
package not found.

Iphome one click fails. Adding the mulliner repo
<http://www.mulliner.org/nokia770/repository chinook free> and install
from app mngr works.

Battlegweled, crazyparking, icebreaker, maemodrac, maemosweeper one
click fails, unable to download xxxxx application package not found.
Download manually from indt garage page.

Numtyphysics one click fails, unable to download xxxxx application
package not found. Download manually from garage page.
<http://numptyphysics.garage.maemo.org/> or

Nako one click works. See note!

Pengupop one click fails, unable to download xxxxx application package
not found.

Gpe sudoku one click fails, unable to download xxxxx application package
not found. Download manually from

Othello one click fails, goes to <>. Add <http://www.harbaum.org/
chinook user> repo and install from app mngr. See note!

Gnumeric does not yet seem available. Bummer, I'll impatiently wait.

Xournal one click works. See note!

Fred one click works. See note!

Maemo mind Download manually from

Tennix download manually from <http://icculus.org/tennix/maemo/>

Ogg one click works, sort of. App mngr Initial install reports as failed
but it's updateable from the update screen. See note!

Contactinfos one click fails. app mngr reports operation failed.
Manually install from

Docreader. Install antiword manually from here
<http://erinye.com/maemo/> then docreader from the garage

Peter Bart <peter at petertheplumber.net>

More information about the maemo-users mailing list