[maemo-users] USB keyboard on n800?

From: Hendrik Boom hendrik at topoi.pooq.com
Date: Sun Sep 28 20:01:46 EEST 2008
On Sun, 28 Sep 2008 08:00:55 -0600, Mark wrote:

> On Sun, Sep 28, 2008 at 6:50 AM, Hendrik Boom <hendrik at topoi.pooq.com>
> wrote:
>> On Sat, 27 Sep 2008 23:49:08 +0100, Matt Emson wrote:
>>> This should get you started...
>>> Get what the mode is currently set:
>>> cat /sys/devices/platform/musb_hdrc/mode)
>>> Turn off the onscreen kbd:
>>> gconftool-2 -t bool -s /system/osso/af/keyboard-attached true
>>> Turn on the onscreen kbd - this is important as is sometimes doesn't
>>> happen -though it should: gconftool-2 -t bool -s
>>> /system/osso/af/keyboard-attached false
>>> Set host mode:
>>> echo host > /sys/devices/platform/musb_hdrc/mode
>> This worked, and it recognized that I had plugged in a USB device.
>> Unfortunately, it indicated this by popping up a window saying "USB
>> device not supported".
>> This message goes away after a second or two.  If I keep my keyboard
>> plugged in and wait a little while, it pops up, "Unable to connect, no
>> file system available".  Well, it would surprise me if it thought my
>> keyboard had a file system.
>> (Although actually, it does have a file system.  It remembers what
>> you've typed in while disconnected, so it can type it in on autopilot
>> when it is connected later.  But I don't think it makes it available as
>> a file system over the USB port.
>> On my desktop Debian machine, it's recognized as an ordinary USB
>> keyboard.  So evidently, there's something else that has to be done.
>> - hendrik
> My Gyration wireless keyboard gives me the same errors, but the keyboard
> works anyway. What's actually happening in my case is that the interface
> includes both keyboard and mouse and the mouse isn't being recognized.
> They apparently omitted and/or disabled any mouse drivers with the
> Tablet OS. My keyboard works normally, however. (The Gyration is the
> only USB keyboard I have.)
> You don't mention whether you went ahead and tried to use the keyboard
> or just gave up when you saw the messages. If you're lucky, it might
> work in spite of the error messages like mine does. If not, it probably
> means that whatever hardware and/or software enables the keyboard to
> utilize the memory function doesn't react 100% like a standard keyboard
> when the OS initiates handshaking. There's not much you can do about
> that, unless you can write and install your own driver...

I did try typing anyway, with no apparent results (I had the root shell 
open at the time).  on Debian Linux on my desktop, I just plug it in, and 
it's recognised and behaves properly.

How does it recognise a keyboard, anyway?  Presumably there's some kind 
of USB ID that identifies the manufacturer and model, and there's a table 
that says what drivers to use.  I don't think the manufacturer developed 
a special driver for Linux.  I suspect if I could get it to try its 
normal USB keyboard driver, it would work.

Does that driver have to be installed specially?

-- hendrik

More information about the maemo-users mailing list