[maemo-users] init.d scripts too picky

From: Marius Gedminas marius at pov.lt
Date: Mon Mar 23 00:58:14 EET 2009
So, I finally got my first N810 back from repairs (turns out it was
fixed months ago, but nobody bothered to give me a call/send an email)
and it was time to install all OS upgrades.

Things did not go smoothly.  For some reason I got conflicting

  osso-software-version-rx44 wanted pre-installed-documentation-rx44 =
  5.4, but 5.7 was going to be picked instead.  The 5.4 was available
  from http://catalogue.tableteer.nokia.com ./, while the 5.7 was
  appearing from http://catalogue.tableteer.nokia.com diablo/user.

I solved that by disabling the two Nokia catalogues (certified and
non-certified) and keeping just the Nokia software update catalogue
(that cannot be disabled anyway).

After that update (and reboot) I got a new update offered (1:5.2008.43-7).
This one started installing and then stopped.  Nothing happened, no
reboot, no anything.  App Installer showed no updates.  Various stuff
stopped working (e.g. Internet radio applet, or the Power menu, or the
desktop menus).  sudo reboot worked and fixed most of the things.

Then I noticed that the App Installer lost most of the catalogues.  It
continued to show me most of those that I had disabled, but it had no
enabled ones (and no Nokia catalogues whatsoever). /etc/apt/sources.list
and /etc/apt/sources.list.d/hildon-application-manager.list were both
empty.  I copied some of the repositories from my other N810,

  deb http://catalogue.tableteer.nokia.com/certified/ diablo user
  deb http://catalogue.tableteer.nokia.com/non-certified/ diablo user
  deb http://catalogue.tableteer.nokia.com/updates/diablo-2/ ./ 

ran sudo apt-get update, opened the App Installer and saw a broken OS
update package.  The App Installer allowed me to try and install it,
which failed with an error.

I'll cut the story short.  The packages could not be configured (in the
dpkg --configure sense) because the respective /etc/init.d/ scripts were

  /etc/init.d/mediaplayer-daemon start
  /etc/init.d/mce start
  /etc/init.d/metalayer-crawler0 start

and the reason they were failing was that those daemons *were already
running*.  I had rebooted after the mysteriously failed upgrade, and
they were started on boot.

Unfortunately, I did not take notes (expecting the upgrades to go
smoothly), so I don't have enough info for proper bug reports.  This
one, however, might be fillable: doesn't the Debian policy require that

  /etc/init.d/service start

do nothing and exit with status code 0 when the service is already
started?  Doesn't the Maemo policy inherit that requirement?

I suppose I should go read both policies and file bugs, but it's 1 AM
and I'm sleepy...

Marius Gedminas
Only great masters of style can succeed in being obtuse.
                -- Oscar Wilde

Most UNIX programmers are great masters of style.
                -- The Unnamed Usenetter
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.maemo.org/pipermail/maemo-users/attachments/20090323/faf6a356/attachment.pgp 
More information about the maemo-users mailing list