[maemo-users] N900 stuck on 5 dots forever

From: Paul Hartman paul.hartman+maemo at gmail.com
Date: Mon Feb 28 18:32:22 EET 2011

Yesterday my N900 froze when I tried to click an icon on the menu.
That happens regularly (maybe once a month) for whatever reason. Maybe
catorise does something weird. I was not at home so no access to SSH
into the phone, so I waited a few minutes and finally held the power
key to shutdown.

Upon restart, it got to the animated 5 dots and kept on there for
hours. Phone still takes a charge during this time (I can get back to
green LED in this state). I had multiboot installed with stock
kernel/power kernel/nitdroid. Stock and power kernel both get stuck in
bootup. Nitdroid still works normally and can get on T-Mobile network,
access SD card etc.

I tried the blind "magic fixes" suggested in forums, namely boot
without SIM, without SD, enable R&D mode, etc. But all of those result
in the same 5 dots animated forever. Of course I didn't expect any of
them to make a difference in this case.

I know reflash of FIASCO image can most likely "fix" it by starting
over, but I'm curious if there is anyway to find out why it's not
progressing beyond the 5 dots. Is there a magic key to disable the 5
dots or some way to see what's going on during the boot process? Like
in a typical linux console during bootup. Maybe then, if I can see
what the problem is, I can boot MeeGo from MicroSD card and edit the
N900's rootfs and keep my customizations. :)

More information about the maemo-users mailing list