[maemo-users] Troubles with chrooted Debian

From: Pavel Řezníček cigydd at gmail.com
Date: Mon Jan 2 13:01:46 EET 2012
My dear Maemo friends,

On my N900, I use the Debian chrooted system but I very often run into troubles with it.

To read quickly, go after the words in italics ;-)

I just need to compile the Lazarus Free Pascal IDE for my device and/or to develop applications with it.
Sometimes it happened when I had Debian in an image file that my N900 suddenly crashed and switched off during the installation of some packages into Debian. So I ran fsck, expecting some damage to the filesystem in that image file. But the corruption appeared so heavy that it was basically unrepairable.
This happenened very frequently so I started to keep a backup of the standard 2GiB image. Still, the loss of work was very annoying… it’s a bit time consuming to backup 2GiB of data after each single step, don’t you think so?
OK, I thought it was better to use a physical device, an MMC SD card. So I’ve formatted an 8GB card to ext3 and copied all the contents of the Debian image onto it using rsync.
I’ve then modified the /home/user/.chroot configuration script accordingly.
All has worked fine except that during installation of the compiled Lazarus (make install) a copy command has frozen for all the night. That was strange, so I pressed Ctrl+C with no effect. I tried to Close Debian. It has also hung. So I’ve turned my device off.
OK, the first run of fsck on /dev/mmcblk1p1 has just recovered the ext3 filesystem journal.
I’ve been curious then if there were some errors left there, so I’ve run fsck -f /dev/mmcblk1p1. Ouch! A destruction of the fs again!

The side question:
Is it a good idea to check an ext3 filesystem right after a journal recovery? Or should I first mount it? I’m apparently lacking an essential knowledge here.

The main question:
Is it possible to avoid severe filesystem damage during just normal but io-intensive operations on the Debian for armel on the N900?

Thank you in advance for just any hint!

Pavel Řezníček
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.maemo.org/pipermail/maemo-users/attachments/20120102/b92a6325/attachment.htm>
More information about the maemo-users mailing list