[maemo-users] n900 and sd card IO errors

From: green greenfreedom10 at gmail.com
Date: Fri Sep 13 03:16:36 UTC 2013
Nokia N900 with SanDisk 32GB class 10 micro SD card.

I have been using this micro SD card with kernel-power v50 for several
months.  Suddenly the N900 reset one day, during or after a phone call
I think.  I thought that was strange, but then noticed that, starting
then, *every* time I tried running unison (triggers lots of IO on SD
card), the N900 would reset.  There was also some strange filesystem
behavior with the Debian chroot on the SD card.  dmesg contains
messages like these (some line breaks added):

mmcblk1: error -110 sending read/write command, \
response 0x0, card status 0x400b00
mmcblk1: error -110 transferring data, sector 15210519, \
nr 1, card status 0x400b00
end_request: I/O error, dev mmcblk1, sector 15210519

(For some reason, it was sometimes 'mmcblk0' instead of 'mmcblk1', but
either way the messages happened only when there is external SD card

e2fsck (using N900 as reader) returns errors like this (line breaks
added again):

Error reading block 1376258 (Attempt to read block from filesystem \
resulted in short read) while getting next inode from scan.  Ignore \

But everything works great with a SD card reader on a regular Linux

So I tried upgrading to kernel-power v52, tried the stock kernel, and
tried reflashing to stock everything.  Same errors.

It seems like from
and <http://www.gossamer-threads.com/lists/maemo/users/65584#65591>
that this error happens with the higher speed class SD cards, but has
been worked around starting with v49 of kernel-power.  Does anyone
have any idea why I suddenly began to experience these IO errors?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.maemo.org/pipermail/maemo-users/attachments/20130912/61dc00c0/attachment.pgp>
More information about the maemo-users mailing list